Bug 129222 - samsung cdrom gives input/output errors on opteron
samsung cdrom gives input/output errors on opteron
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: magicdev (Show other bugs)
3.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-05 07:42 EDT by Erik Schaberg
Modified: 2013-03-05 22:41 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 15:21:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output of dmesg -s 65536 (19.09 KB, text/plain)
2004-08-11 04:53 EDT, Erik Schaberg
no flags Details

  None (edit)
Description Erik Schaberg 2004-08-05 07:42:48 EDT
Description of problem:
Accessing file on CDROM give "Input/Outut error" at prompt and
"attempt to access beyond end of device
03:00: rw=0, want=393400, limit=10560" in dmesg.
.


Version-Release number of selected component (if applicable):
it is a fresh install of Red hat enterprise AS v3.
uname -a:
Linux xxxxxx.xxxxx.xxxx 2.4.21-15.ELsmp #1 SMP Thu Apr 22 00:09:01 EDT
2004 x86_64 x86_64 x86_64 GNU/Linux


How reproducible:
I have this strange problem on all my new opteron boxes. They all have
the same cdrom player (samsung ide cdrom sn-124), and when  cp
nedit-5.3-4.x86_64.rpm /tmp
cp: reading `nedit-5.3-4.x86_64.rpm': Input/output error
I installed the system from cdrom, it worked fine, but after the
reboot I get strange errors. Fedora core 1 does not have the problem.

Steps to Reproduce:
1. (auto)mount cdrom (for example 2nd installation cdrom)
2. cd /mnt/cdrom/RedHat/RPMS
3. ls (works fine)
4. cp nedit-5.3-4.x86_64.rpm /tmp
cp: reading `nedit-5.3-4.x86_64.rpm': Input/output error
 
Actual results:
Emty file is created in /tmp and dmesg will show "attempt to access
beyond end of device" errors.

Expected results:
file copied to /tmp

Additional info:
 I can mount the cdroms and look at directory listings but when I copy
files from it I get this error: Input/output error
[root@xxxxxx root]# cd /mnt/cdrom/RedHat/RPMS/
[root@xxxxxx RPMS]# cp nedit-5.3-4.x86_64.rpm /tmp
cp: reading `nedit-5.3-4.x86_64.rpm': Input/output error

dmesg will also show beyond end of device errors:
ISO 9660 Extensions: Microsoft Joliet Level 3
ISO 9660 Extensions: RRIP_1991A
attempt to access beyond end of device
03:00: rw=0, want=393400, limit=10560
attempt to access beyond end of device
03:00: rw=0, want=393402, limit=10560

I installed fedora core 1, and everything works fine. All the 'faulty'
drives and cdrom disks work fine again. While installing the system,
it also read the same cdroms. So it is clearly a RHEL AS v3 x86_64
problem.
                                                                     
          
mount show that the cdrom in mounted as an iso9660 type filesystem.
[root@gerald4 RPMS]# mount
/dev/cdrom on /mnt/cdrom type iso9660 (ro,nosuid,nodev)
Comment 1 Erik Schaberg 2004-08-06 06:58:41 EDT
I upgraded the fedora core 1 to the new fedora core 2 (x86_64) and 
the cdrom input/output error is not happening.

So it must be a driver problem in AS v3.

I tested some more in RHEL AS v3:
it looks like if the system is booted with the cdrom inside, it works 
ok. I can mount read/ unmount, mount again and read again. But when I 
change the cdrom (open close drive) it will mount ok, give me 
directory listings, but I cannot copy RPM files from it. Same 
input/output error and "attempt to access beyond end of device" 
errors in dmesg.
So it has also something to do with the size of the file that is 
accessed. 

What kind of tests/commands should I run to provide you guys with 
more technical input?





Comment 2 Jim Paradis 2004-08-09 13:54:48 EDT
For starters, do a "dmesg -s 65536" and attach the output to this bug
report.  This will give us some idea of how the system sees the device
at startup.
Comment 3 Erik Schaberg 2004-08-11 04:53:31 EDT
Created attachment 102605 [details]
output of dmesg -s 65536

this is the dmesg on the RHEL AS v3.
the cdrom driver is version 3.12.
on fedore core 2 boot the cdrom driver loaded is version 3.20.
Comment 4 Erik Schaberg 2004-08-12 11:49:58 EDT
IMPORTANT UPDATE:

This problem only happens in gnome. After booting to runlevel 3 the 
cdrom works fine. (So there is probably nothing wrong with the CDROM 
driver.)

I try different cdrom options in the gnome control panel, unchecking 
automount, unchecking the various autorun options. But I have not 
been able to fix it. So I'm unable to use the add/remove applications 
function in gnome. It only works properly if the packages are on the 
current cd. After one cdrom change the problem keeps happening, even 
if I do an init 3 (after mounting a cdrom in gnome) and continue to 
mount and unmount from the command prompt at runlevel 3 I keep 
getting the input/output error in combination of the "attempt to 
access beyond end of device" errors in dmesg.


Comment 5 Erik Schaberg 2004-08-13 04:45:22 EDT
I think I have found the work-around. After the tip of Michael K. 
Johnson in bug 11144 I removed magicdev. And I have not had the 
problem anymore.

Fedora core 2 did not have the problem, so I'm going to try to update 
magicdev and maybe my kernel. But for this production system I rather 
stay in line with the RHN updates, and not go for the bleeding edge.

All suggestions on what si the wised path are welcome.

I never expected this to happen with RHEL AS, I thouight it would be 
more stable than the fedora, but with my opteron server I had more 
problems with RHEL AS than with fedora. I even had to trade in my 
adaptec raid controller (see bug 128482) for a megaraid one to get it 
to work with RHEL AS.

 
Comment 6 Jim Paradis 2004-08-16 13:42:57 EDT
Reassigning bug to the magicdev maintainer.
Comment 7 John (J5) Palmieri 2004-08-16 21:23:28 EDT
It seems that the only change was an upgrade from magicdev 1.1.4 to
1.1.6.  I will take a closer look at the change set between the two
version and see if I can backport a patch or perhaps just bump it up
if not much has changed.  Magicdev will be obsoleted in the future by
gnome-volume-manager.
Comment 8 John (J5) Palmieri 2004-10-04 17:28:41 EDT
Looks like it is an issue between magicdev and the kernel because all
the new functionality in magicdev-1.1.6 had been backported to the
1.1.4 package.  Upgrading to the new magicdev will not fix this problem.
Comment 9 RHEL Product and Program Management 2007-10-19 15:21:24 EDT
This bug is filed against RHEL 3, which is in maintenance phase.
During the maintenance phase, only security errata and select mission
critical bug fixes will be released for enterprise products. Since
this bug does not meet that criteria, it is now being closed.
 
For more information of the RHEL errata support policy, please visit:
http://www.redhat.com/security/updates/errata/
 
If you feel this bug is indeed mission critical, please contact your
support representative. You may be asked to provide detailed
information on how this bug is affecting you.

Note You need to log in before you can comment on or make changes to this bug.