Bug 1292220 - network association missing from vm.hardware.nics
network association missing from vm.hardware.nics
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate (Show other bugs)
5.4.0
All All
unspecified Severity medium
: GA
: 5.5.2
Assigned To: Lucy Fu
Pete Savage
: ZStream
Depends On: 1291891 1301084
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-16 13:50 EST by Lucy Fu
Modified: 2016-02-10 10:28 EST (History)
12 users (show)

See Also:
Fixed In Version: 5.5.2.1
Doc Type: Bug Fix
Doc Text:
In the previous version of CloudForms Management Engine, looking up a virtual machine's network device information in automate methods would result in an error. This was because network association was missing from the vm.hardware.nics network object. This bug was fixed by exposing network information from the hardware service model. It is now possible to use the vm.hardware.nics object in automate methods.
Story Points: ---
Clone Of: 1291891
Environment:
Last Closed: 2016-02-10 10:28:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 CFME Bot 2015-12-17 08:52:03 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=66e78342cc6d79ac453ed738a2063f1fe70c95e5

commit 66e78342cc6d79ac453ed738a2063f1fe70c95e5
Merge: 31de83b 8acaf89
Author:     Greg McCullough <gmccullo@redhat.com>
AuthorDate: Thu Dec 17 08:49:05 2015 -0500
Commit:     Greg McCullough <gmccullo@redhat.com>
CommitDate: Thu Dec 17 08:49:05 2015 -0500

    Merge branch '5.5.z-expose_networks_from_hardware_service_model_1291891' into '5.5.z'
    
    Expose networks from hardware service model.
    
    Clean cherry-pick of [original](https://github.com/ManageIQ/manageiq/pull/5865)
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1292220
    
    See merge request !629

 lib/miq_automation_engine/service_models/miq_ae_service_hardware.rb | 1 +
 1 file changed, 1 insertion(+)
Comment 7 errata-xmlrpc 2016-02-10 10:28:42 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0159

Note You need to log in before you can comment on or make changes to this bug.