Bug 1301084 - network association missing from vm.hardware.nics
network association missing from vm.hardware.nics
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate (Show other bugs)
5.4.0
All All
unspecified Severity medium
: GA
: 5.4.5
Assigned To: Lucy Fu
Alex Newman
automate:network
: ZStream
Depends On: 1291891
Blocks: 1292220
  Show dependency treegraph
 
Reported: 2016-01-22 09:38 EST by Chris Pelland
Modified: 2016-03-29 10:17 EDT (History)
13 users (show)

See Also:
Fixed In Version: 5.4.5.2
Doc Type: Bug Fix
Doc Text:
Previously, network association was missing from vm.hardware.nics. This made it unable to map network devices to their respective IPs. This patch exposes networks from hardware service model and the issue is now resolved.
Story Points: ---
Clone Of: 1291891
Environment:
Last Closed: 2016-03-29 10:17:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 CFME Bot 2016-02-09 17:47:56 EST
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=9372e7cca0c738e0c9b1a995d5d404c5efffda4b

commit 9372e7cca0c738e0c9b1a995d5d404c5efffda4b
Merge: a689015 4e24065
Author:     Greg McCullough <gmccullo@redhat.com>
AuthorDate: Tue Feb 9 17:31:29 2016 -0500
Commit:     Greg McCullough <gmccullo@redhat.com>
CommitDate: Tue Feb 9 17:31:29 2016 -0500

    Merge branch '5.4.z-expose_networks_from_hardware_service_model_1291891' into '5.4.z'
    
    Expose networks from hardware service model.
    
    Clean cherry-pick from [original](https://github.com/ManageIQ/manageiq/pull/5865)
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1301084
    
    See merge request !759

 vmdb/lib/miq_automation_engine/service_models/miq_ae_service_hardware.rb | 1 +
 1 file changed, 1 insertion(+)
Comment 4 Pete Savage 2016-03-21 07:06:03 EDT
Verified in 5.4.5.2
Comment 6 errata-xmlrpc 2016-03-29 10:17:29 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0171.html

Note You need to log in before you can comment on or make changes to this bug.