Bug 1292226 - Remove Sat 5 from Registration options for 5.5
Remove Sat 5 from Registration options for 5.5
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.5.2
Assigned To: Nick Carboni
Jan Krocil
: ZStream
Depends On: 1291872
Blocks: 1291951
  Show dependency treegraph
 
Reported: 2015-12-16 14:08 EST by John Prause
Modified: 2016-02-10 10:28 EST (History)
13 users (show)

See Also:
Fixed In Version: 5.5.2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1291872
Environment:
Last Closed: 2016-02-10 10:28:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Gregg Tanzillo 2015-12-21 10:04:41 EST
PR: https://github.com/ManageIQ/manageiq/pull/5914
Comment 4 CFME Bot 2015-12-22 13:22:59 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=bc4820e660457b83532a32378a6495c5ab8db86f

commit bc4820e660457b83532a32378a6495c5ab8db86f
Author:     Nick Carboni <ncarboni@redhat.com>
AuthorDate: Thu Oct 15 16:26:04 2015 -0400
Commit:     Nick Carboni <ncarboni@redhat.com>
CommitDate: Tue Dec 22 10:48:00 2015 -0500

    Add migration to remove registration information for Sat5 updates
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1292226

 .../20151221134925_remove_sat5_repo_config.rb      | 34 ++++++++++++++
 .../20151221134925_remove_sat5_repo_config_spec.rb | 52 ++++++++++++++++++++++
 2 files changed, 86 insertions(+)
 create mode 100644 db/migrate/20151221134925_remove_sat5_repo_config.rb
 create mode 100644 spec/migrations/20151221134925_remove_sat5_repo_config_spec.rb
Comment 5 CFME Bot 2015-12-22 13:23:04 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=918327db5c4c08de44c26262e0587dba5c7f303c

commit 918327db5c4c08de44c26262e0587dba5c7f303c
Author:     Nick Carboni <ncarboni@redhat.com>
AuthorDate: Thu Oct 15 13:45:34 2015 -0400
Commit:     Nick Carboni <ncarboni@redhat.com>
CommitDate: Tue Dec 22 10:48:21 2015 -0500

    Updated rhn repo names
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1292226

 app/controllers/ops_controller/settings/rhn.rb | 2 +-
 app/models/miq_database.rb                     | 7 ++-----
 2 files changed, 3 insertions(+), 6 deletions(-)
Comment 6 CFME Bot 2015-12-22 13:23:10 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=178c92f01ffab9a2652119a77bddc7b3fe23c36c

commit 178c92f01ffab9a2652119a77bddc7b3fe23c36c
Author:     Nick Carboni <ncarboni@redhat.com>
AuthorDate: Thu Oct 15 16:26:45 2015 -0400
Commit:     Nick Carboni <ncarboni@redhat.com>
CommitDate: Tue Dec 22 10:48:27 2015 -0500

    Remove Sat5 menu option
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1292226

 app/controllers/ops_controller/settings/rhn.rb | 1 -
 1 file changed, 1 deletion(-)
Comment 7 CFME Bot 2015-12-22 13:23:15 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=c6eade5acd5c4449e25cef7bcf4ff81a5aae0951

commit c6eade5acd5c4449e25cef7bcf4ff81a5aae0951
Author:     Nick Carboni <ncarboni@redhat.com>
AuthorDate: Thu Oct 15 16:34:26 2015 -0400
Commit:     Nick Carboni <ncarboni@redhat.com>
CommitDate: Tue Dec 22 10:48:38 2015 -0500

    Remove registration_server_url_is_valid
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1292226

 app/models/miq_database.rb | 8 --------
 1 file changed, 8 deletions(-)
Comment 8 CFME Bot 2015-12-22 13:23:21 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=42a9534d1ea5560678cab81fbb27dd5b27892e89

commit 42a9534d1ea5560678cab81fbb27dd5b27892e89
Author:     Nick Carboni <ncarboni@redhat.com>
AuthorDate: Thu Oct 15 16:56:13 2015 -0400
Commit:     Nick Carboni <ncarboni@redhat.com>
CommitDate: Tue Dec 22 10:48:48 2015 -0500

    Remove UI references to rhn_satellite registration type
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1292226

 app/views/ops/_settings_rhn_edit_tab.html.haml | 12 ++----------
 app/views/ops/rhn/_info_subscribed.html.haml   |  2 +-
 2 files changed, 3 insertions(+), 11 deletions(-)
Comment 9 CFME Bot 2015-12-22 13:23:26 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=b60f2eb52dcef2b48fa48e92f5386355502d2f80

commit b60f2eb52dcef2b48fa48e92f5386355502d2f80
Author:     Nick Carboni <ncarboni@redhat.com>
AuthorDate: Thu Oct 15 16:38:48 2015 -0400
Commit:     Nick Carboni <ncarboni@redhat.com>
CommitDate: Tue Dec 22 10:48:44 2015 -0500

    Remove references to Sat5 in miq_server/update_management.rb
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1292226

 app/models/miq_server/update_management.rb       |  8 ++------
 spec/models/miq_server/update_management_spec.rb | 24 ------------------------
 2 files changed, 2 insertions(+), 30 deletions(-)
Comment 10 CFME Bot 2015-12-22 13:23:31 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=17a8aace8459559d3b5c32d94bbaea63a55e6df4

commit 17a8aace8459559d3b5c32d94bbaea63a55e6df4
Author:     Nick Carboni <ncarboni@redhat.com>
AuthorDate: Thu Oct 15 16:32:56 2015 -0400
Commit:     Nick Carboni <ncarboni@redhat.com>
CommitDate: Tue Dec 22 10:48:32 2015 -0500

    Remove rhn_validate_enabled method
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1292226

 app/controllers/ops_controller/settings/rhn.rb | 7 -------
 app/views/ops/_settings_rhn_edit_tab.html.haml | 2 +-
 2 files changed, 1 insertion(+), 8 deletions(-)
Comment 12 Jan Krocil 2016-01-18 10:22:33 EST
Verified fixed in 5.5.2.1 - 5.5.2.1.20160114044944_395c086.

Satellite 5 registration is no longer available in the web UI.
Comment 13 errata-xmlrpc 2016-02-10 10:28:46 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0159

Note You need to log in before you can comment on or make changes to this bug.