Bug 1291872 - Remove Sat 5 from Registration options for 5.5
Remove Sat 5 from Registration options for 5.5
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity high
: GA
: 5.6.0
Assigned To: Nick Carboni
Alex Newman
:
: 1290452 (view as bug list)
Depends On:
Blocks: 1291951 1292226
  Show dependency treegraph
 
Reported: 2015-12-15 14:18 EST by Marianne Feifer
Modified: 2016-06-29 11:20 EDT (History)
9 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1292226 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:20:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Updates page (179.73 KB, image/png)
2015-12-15 14:18 EST, Marianne Feifer
no flags Details

  None (edit)
Description Marianne Feifer 2015-12-15 14:18:39 EST
Created attachment 1106136 [details]
Updates page

Description of problem:Red Hat Satellite 5 is no longer supported for registering/updating the CFME Appliance, but the dropdown under Configure-Configuration-Region-Red Hat Updates still shows it. 


Version-Release number of selected component (if applicable): 5.5


How reproducible: Always


Steps to Reproduce:
1.Go to Configure-Configuration-Region-Red Hat Updates
2.Click Register to dropdown.
3.

Actual results:
Satellite 5 is an option

Expected results:
Satellite 5 should not be seen.


Additional info:
Comment 2 Marianne Feifer 2015-12-15 14:19:46 EST
Guides will need updating after this is complete.
Comment 4 Dan Clarizio 2015-12-17 12:42:20 EST
*** Bug 1290452 has been marked as a duplicate of this bug. ***
Comment 9 CFME Bot 2015-12-22 10:31:35 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/7247e7946d8f786b06f550c00187535894f51f15

commit 7247e7946d8f786b06f550c00187535894f51f15
Author:     Nick Carboni <ncarboni@redhat.com>
AuthorDate: Thu Oct 15 13:45:34 2015 -0400
Commit:     Nick Carboni <ncarboni@redhat.com>
CommitDate: Mon Dec 21 08:59:42 2015 -0500

    Updated rhn repo names
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1291872

 app/controllers/ops_controller/settings/rhn.rb | 2 +-
 app/models/miq_database.rb                     | 7 ++-----
 2 files changed, 3 insertions(+), 6 deletions(-)
Comment 10 CFME Bot 2015-12-22 10:31:41 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/263dd157a2561bba0d4e557c89e28bf901d285f7

commit 263dd157a2561bba0d4e557c89e28bf901d285f7
Author:     Nick Carboni <ncarboni@redhat.com>
AuthorDate: Thu Oct 15 16:26:45 2015 -0400
Commit:     Nick Carboni <ncarboni@redhat.com>
CommitDate: Mon Dec 21 08:59:42 2015 -0500

    Remove Sat5 menu option
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1291872

 app/controllers/ops_controller/settings/rhn.rb | 1 -
 1 file changed, 1 deletion(-)
Comment 11 CFME Bot 2015-12-22 10:31:46 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/afe6fff0613029ced179e75bd3c53d581a2c0ca2

commit afe6fff0613029ced179e75bd3c53d581a2c0ca2
Author:     Nick Carboni <ncarboni@redhat.com>
AuthorDate: Thu Oct 15 16:32:56 2015 -0400
Commit:     Nick Carboni <ncarboni@redhat.com>
CommitDate: Mon Dec 21 08:59:42 2015 -0500

    Remove rhn_validate_enabled method
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1291872

 app/controllers/ops_controller/settings/rhn.rb | 7 -------
 app/views/ops/_settings_rhn_edit_tab.html.haml | 2 +-
 2 files changed, 1 insertion(+), 8 deletions(-)
Comment 12 CFME Bot 2015-12-22 10:31:51 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/7bdc7056c84ee08dbb0c29d211ad16ec0f5563bd

commit 7bdc7056c84ee08dbb0c29d211ad16ec0f5563bd
Author:     Nick Carboni <ncarboni@redhat.com>
AuthorDate: Thu Oct 15 16:56:13 2015 -0400
Commit:     Nick Carboni <ncarboni@redhat.com>
CommitDate: Mon Dec 21 08:59:42 2015 -0500

    Remove UI references to rhn_satellite registration type
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1291872

 app/views/ops/_settings_rhn_edit_tab.html.haml | 12 ++----------
 app/views/ops/rhn/_info_subscribed.html.haml   |  2 +-
 2 files changed, 3 insertions(+), 11 deletions(-)
Comment 13 CFME Bot 2015-12-22 10:31:56 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/704d0405f76182d3c2000821b68d2c561acd42e4

commit 704d0405f76182d3c2000821b68d2c561acd42e4
Author:     Nick Carboni <ncarboni@redhat.com>
AuthorDate: Thu Oct 15 16:38:48 2015 -0400
Commit:     Nick Carboni <ncarboni@redhat.com>
CommitDate: Mon Dec 21 08:59:42 2015 -0500

    Remove references to Sat5 in miq_server/update_management.rb
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1291872

 app/models/miq_server/update_management.rb       |  8 ++------
 spec/models/miq_server/update_management_spec.rb | 24 ------------------------
 2 files changed, 2 insertions(+), 30 deletions(-)
Comment 14 CFME Bot 2015-12-22 10:32:02 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/8b8621b29cf31b8929620cf9c9e45b5f2f2fd4f8

commit 8b8621b29cf31b8929620cf9c9e45b5f2f2fd4f8
Author:     Nick Carboni <ncarboni@redhat.com>
AuthorDate: Thu Oct 15 16:34:26 2015 -0400
Commit:     Nick Carboni <ncarboni@redhat.com>
CommitDate: Mon Dec 21 08:59:42 2015 -0500

    Remove registration_server_url_is_valid
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1291872

 app/models/miq_database.rb | 8 --------
 1 file changed, 8 deletions(-)
Comment 15 CFME Bot 2015-12-22 10:32:08 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/f14333c56c37505993af053bfbf77153f947028e

commit f14333c56c37505993af053bfbf77153f947028e
Author:     Nick Carboni <ncarboni@redhat.com>
AuthorDate: Thu Oct 15 16:26:04 2015 -0400
Commit:     Nick Carboni <ncarboni@redhat.com>
CommitDate: Mon Dec 21 08:58:42 2015 -0500

    Add migration to remove registration information for Sat5 updates
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1291872

 .../20151221134925_remove_sat5_repo_config.rb      | 34 ++++++++++++++
 .../20151221134925_remove_sat5_repo_config_spec.rb | 52 ++++++++++++++++++++++
 2 files changed, 86 insertions(+)
 create mode 100644 db/migrate/20151221134925_remove_sat5_repo_config.rb
 create mode 100644 spec/migrations/20151221134925_remove_sat5_repo_config_spec.rb
Comment 16 Alex Newman 2016-04-27 15:41:16 EDT
5.6.0.4-beta2.3.20160421172650_719e256
Comment 18 errata-xmlrpc 2016-06-29 11:20:57 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.