Bug 1292253 - Production + EPEL + yum-plugin-priorities results in wrong version of hiera
Production + EPEL + yum-plugin-priorities results in wrong version of hiera
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: rdo-manager (Show other bugs)
Liberty
Unspecified Unspecified
unspecified Severity unspecified
: ---
: trunk
Assigned To: John Trowbridge
Shai Revivo
:
: 1294687 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-16 15:21 EST by Steve Linabery
Modified: 2017-06-18 02:17 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-18 02:17:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Linabery 2015-12-16 15:21:01 EST
Description of problem:
When doing a khaleesi-based install on centos with liberty production repo enabled, and attempting to build the undercloud image, the wrong version of hiera is pulled in from the repos

[stack@instack ~]$ grep -B 5 ERROR undercloud_install_initial_install.log 
+ '[' -f /opt/stack/.undercloud-setup ']'
+ source /root/tripleo-undercloud-passwords
+++ sudo hiera admin_password
Failed to start Hiera: RuntimeError: Config file /etc/puppetlabs/code/hiera.yaml not found
++ UNDERCLOUD_ADMIN_PASSWORD=
[2015-12-16 05:17:30,902] (os-refresh-config) [ERROR] during post-configure phase. [Command '['dib-run-parts', '/usr/libexec/os-refresh-config/post-configure.d']' returned non-zero exit status 1]

[2015-12-16 05:17:30,902] (os-refresh-config) [ERROR] Aborting...
[stack@instack ~]$ grep -B 10 ERROR undercloud_install_initial_install.log 
++ iptables -D FORWARD -j REJECT --reject-with icmp-host-prohibited
+ iptables-save
dib-run-parts Wed Dec 16 05:17:30 UTC 2015 80-seedstack-masquerade completed
dib-run-parts Wed Dec 16 05:17:30 UTC 2015 Running /usr/libexec/os-refresh-config/post-configure.d/98-undercloud-setup
+ OK_FILE=/opt/stack/.undercloud-setup
+ '[' -f /opt/stack/.undercloud-setup ']'
+ source /root/tripleo-undercloud-passwords
+++ sudo hiera admin_password
Failed to start Hiera: RuntimeError: Config file /etc/puppetlabs/code/hiera.yaml not found
++ UNDERCLOUD_ADMIN_PASSWORD=
[2015-12-16 05:17:30,902] (os-refresh-config) [ERROR] during post-configure phase. [Command '['dib-run-parts', '/usr/libexec/os-refresh-config/post-configure.d']' returned non-zero exit status 1]

[2015-12-16 05:17:30,902] (os-refresh-config) [ERROR] Aborting...
[stack@instack ~]$ rpm -qa | grep hiera
hiera-3.0.1-1.el7.noarch
[stack@instack ~]$ rpm -qa | grep prioriti
yum-plugin-priorities-1.1.31-34.el7.noarch
[stack@instack ~]$ yum -d 10 repolist
Loading "fastestmirror" plugin
Loading "priorities" plugin
Config time: 0.005
Yum version: 3.4.3
Determining fastest mirrors
 * epel: mirror.steadfast.net
Setting up Package Sacks
pkgsack time: 0.004
Repo-id      : base/7/x86_64
Repo-name    : CentOS-7 - Base
Repo-revision: 1449700451
Repo-updated : Wed Dec  9 22:35:45 2015
Repo-pkgs    : 9,007
Repo-size    : 6.5 G
Repo-baseurl : http://mirror.centos.org/centos/7/os/x86_64/
Repo-expire  : 21,600 second(s) (last: Wed Dec 16 05:09:51 2015)
Repo-filename: /etc/yum.repos.d/CentOS-Base.repo

Repo-id      : epel/x86_64
Repo-name    : Extra Packages for Enterprise Linux 7 - x86_64
Repo-revision: 1450160150
Repo-tags    : binary-x86_64
Repo-updated : Tue Dec 15 06:22:10 2015
Repo-pkgs    : 8,957
Repo-size    : 7.1 G
Repo-metalink: https://mirrors.fedoraproject.org/metalink?repo=epel-7&arch=x86_64
  Updated    : Tue Dec 15 06:22:10 2015
Repo-baseurl : http://mirror.steadfast.net/epel/7/x86_64/ (31 more)
Repo-expire  : 21,600 second(s) (last: Wed Dec 16 05:09:51 2015)
Repo-filename: /etc/yum.repos.d/epel.repo

Repo-id      : extras/7/x86_64
Repo-name    : CentOS-7 - Extras
Repo-revision: 1449796901
Repo-updated : Fri Dec 11 01:21:57 2015
Repo-pkgs    : 190
Repo-size    : 547 M
Repo-baseurl : http://mirror.centos.org/centos/7/extras/x86_64/
Repo-expire  : 21,600 second(s) (last: Wed Dec 16 05:09:51 2015)
Repo-filename: /etc/yum.repos.d/CentOS-Base.repo

Repo-id      : openstack-liberty/x86_64
Repo-name    : OpenStack Liberty Repository
Repo-revision: 1449486155
Repo-updated : Mon Dec  7 11:02:43 2015
Repo-pkgs    : 801
Repo-size    : 389 M
Repo-baseurl : http://mirror.centos.org/centos/7/cloud/x86_64/openstack-liberty/
Repo-expire  : 21,600 second(s) (last: Wed Dec 16 05:09:51 2015)
Repo-filename: /etc/yum.repos.d/rdo-release.repo

Repo-id      : updates/7/x86_64
Repo-name    : CentOS-7 - Updates
Repo-revision: 1450230323
Repo-updated : Wed Dec 16 01:46:07 2015
Repo-pkgs    : 347
Repo-size    : 1.0 G
Repo-baseurl : http://mirror.centos.org/centos/7/updates/x86_64/
Repo-expire  : 21,600 second(s) (last: Wed Dec 16 05:09:51 2015)
Repo-filename: /etc/yum.repos.d/CentOS-Base.repo

repolist: 19,302
Comment 1 Mohammed Arafa 2015-12-16 23:05:47 EST
i get this same error when i am installing the undercloud
Comment 2 John Trowbridge 2015-12-17 16:26:10 EST
I think the bug we would really like to fix here is installing EPEL in the first place. Without EPEL installed, this issue never would happen. There are a couple places where there is a check for EPEL in instack-undercloud that will need to be patched out.

There is also at least one package (python-proliantutils) that needs to make its way into CBS.

I will work on both of these.
Comment 3 Frank 2015-12-28 22:21:10 EST
As a temporary work around, the following edit on the undercloud machine allows for installation of the right version. 

File name: /etc/yum.repos.d/epel.repo

Add the following in the [epel] section of the file

exclude=hiera*

This forced the epel repository to be ignored when pulling hiera, allowing for the right version to be installed. 

This is very much a hack and just offered to allow people who are being stumped by this bug (like me) to get past this step until a proper fix is implemented.
Comment 4 Alexander Chuzhoy 2015-12-29 12:20:58 EST
*** Bug 1294687 has been marked as a duplicate of this bug. ***
Comment 6 Christopher Brown 2017-06-17 14:51:56 EDT
Can be closed as I'm pretty sure this is fixed :p

Note You need to log in before you can comment on or make changes to this bug.