Bug 1294687 - instack-undercloud: "openstack undercloud install" exits after error "Failed to start Hiera: RuntimeError: Config file /etc/puppetlabs/code/hiera.yaml not found".
instack-undercloud: "openstack undercloud install" exits after error "Failed ...
Status: CLOSED DUPLICATE of bug 1292253
Product: RDO
Classification: Community
Component: instack-undercloud (Show other bugs)
Liberty
Unspecified Unspecified
unspecified Severity unspecified
: ---
: Liberty
Assigned To: James Slagle
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-29 12:07 EST by Alexander Chuzhoy
Modified: 2016-04-18 03:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-29 12:20:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Chuzhoy 2015-12-29 12:07:33 EST
instack-undercloud: "openstack undercloud install" exits after error "Failed to start Hiera: RuntimeError: Config file /etc/puppetlabs/code/hiera.yaml not found".



Environment:
instack-undercloud-2.1.3-1.el7.noarch
openstack-selinux-0.6.43-1.el7ost.noarch
OS: rhel7.1


Steps to reproduce:
1. Follow this guide: https://repos.fedorapeople.org/repos/openstack-m/rdo-manager-docs/liberty/installation/installing.html

2. Set selinux to permissive due to BZ #1294683

3. Run "openstack undercloud install"

Result:

+ iptables-save
dib-run-parts Tue Dec 29 11:58:02 EST 2015 80-seedstack-masquerade completed
dib-run-parts Tue Dec 29 11:58:02 EST 2015 Running /usr/libexec/os-refresh-config/post-configure.d/98-undercloud-setup
+ OK_FILE=/opt/stack/.undercloud-setup
+ '[' -f /opt/stack/.undercloud-setup ']'
+ source /root/tripleo-undercloud-passwords
+++ sudo hiera admin_password
Failed to start Hiera: RuntimeError: Config file /etc/puppetlabs/code/hiera.yaml not found
++ UNDERCLOUD_ADMIN_PASSWORD=
[2015-12-29 11:58:02,315] (os-refresh-config) [ERROR] during post-configure phase. [Command '['dib-run-parts', '/usr/libexec/os-refresh-config/post-configure.d']' returned non-zero exit status 1]

[2015-12-29 11:58:02,316] (os-refresh-config) [ERROR] Aborting...
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 562, in install
    _run_orc(instack_env)
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 494, in _run_orc
    _run_live_command(args, instack_env, 'os-refresh-config')
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 325, in _run_live_command
    raise RuntimeError('%s failed. See log for details.' % name)
RuntimeError: os-refresh-config failed. See log for details.
Command 'instack-install-undercloud' returned non-zero exit status 1



Expected result:
Successfully deployed undercloud.
Comment 1 Alexander Chuzhoy 2015-12-29 12:20:58 EST

*** This bug has been marked as a duplicate of bug 1292253 ***

Note You need to log in before you can comment on or make changes to this bug.