Bug 129237 - Printed jobs remains in windows print manager
Printed jobs remains in windows print manager
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: samba (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
David Lawrence
http://lists.samba.org/archive/samba/...
:
: IT_53506 (view as bug list)
Depends On:
Blocks: 132991 168749
  Show dependency treegraph
 
Reported: 2004-08-05 10:17 EDT by Jorgen Ostling
Modified: 2014-08-31 19:26 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-18 11:21:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
samba config file (7.11 KB, text/plain)
2004-08-05 10:24 EDT, Jorgen Ostling
no flags Details
Fix for Printed jobs remains in windows print manager taken from bug #2220 on bugzilla.samba.org (386 bytes, patch)
2005-02-14 18:41 EST, root
no flags Details | Diff

  None (edit)
Description Jorgen Ostling 2004-08-05 10:17:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.2)
Gecko/20040301

Description of problem:
The Windows printer queue show active jobs even *after* the job has
completed.
(I have a mixed set of clients - mostly Windows 2000 and some Windows XP)
Samba is configured to use cups raw printer queue.

(See attached smb.conf)



Version-Release number of selected component (if applicable):
samba-3.0.4-6.3E

How reproducible:
Always

Steps to Reproduce:
1. Submit print job from windows
2. Check windows print manager

    

Actual Results:  The print job remains in windows print manager even
though
the job is printed.
/var/spool/samba and /var/spool/cups is empty (no spool files).

Expected Results:  Windows print manager should be empty

Additional info:

See attached smb.conf
Comment 1 Jorgen Ostling 2004-08-05 10:24:32 EDT
Created attachment 102449 [details]
samba config file
Comment 2 Gunther Schlegel 2004-08-17 09:27:30 EDT
We experience the same problem with samba-3.0.5-2.FC2.1 from FC2
testing. 3.0.3-5 is fine.
Comment 3 Seth Vidal 2004-09-01 17:23:50 EDT
We've seen the same thing here on el3.

Comment 4 Petr Houzvik 2004-09-02 12:47:18 EDT
This problem is solved in samba-3.0.6-2.3E.
Comment 5 root 2005-02-14 18:38:41 EST
We have this problem still in 3.0.9-1.3E.2. We have Windows XP Pro clients
printing to samba (authentication done using domain login) which uses a CUPS
service on the same machine to do the printing.

We fixed it by downloading the SRPM for samba-3.0.9-1.3E.2, adding the following
patch to the spec file and recompiling. It would be nice if RedHat could include
this patch in their next update of the samba packages.

For more info see https://bugzilla.samba.org/show_bug.cgi?id=2220
Comment 6 root 2005-02-14 18:41:04 EST
Created attachment 111071 [details]
Fix for Printed jobs remains in windows print manager taken from bug #2220 on bugzilla.samba.org

I've tested this being applied to the latest samba SRPM for RHEL U4 and it
works for us.
Comment 7 Milan Kerslager 2005-02-16 12:53:20 EST
As of taroon-list@redhat.com you may have to remove
/var/cache/samba/printing/*.tdb to empty print queues with stale
entries. I made RPM packages for actual Samba for i386 and AMD64 too:

ftp://ftp.pslib.cz/pub/users/Milan.Kerslager/RHEL-3/testing.samba
Comment 8 Bastien Nocera 2005-02-21 06:30:24 EST
*** Bug 145639 has been marked as a duplicate of this bug. ***
Comment 10 Milan Kerslager 2005-02-21 06:51:03 EST
My fixed packages are working well here (see comment #7).
Comment 11 root 2005-02-21 17:14:31 EST
My fixed packages are working perfectly too. Could RedHat please make
sure they roll this fix into the next samba update.
Comment 12 Milan Kerslager 2005-03-29 10:48:08 EST
According to the changelog, Samba from upcoming U5 (in Beta channel at this time
- samba-3.0.9-1.3E.3.src.rpm) will have the one-line patch included together
with the fix for bug #134310.
Comment 13 Tim Powers 2005-05-18 11:21:48 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-292.html

Note You need to log in before you can comment on or make changes to this bug.