Bug 1292461 - FTBFS: truncated files
FTBFS: truncated files
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python3 (Show other bugs)
24
powerpc Linux
unspecified Severity high
: ---
: ---
Assigned To: Charalampos Stratakis
Fedora Extras Quality Assurance
:
Depends On:
Blocks: PPCTracker 1287556 1292462 1292467
  Show dependency treegraph
 
Reported: 2015-12-17 09:12 EST by Karsten Hopp
Modified: 2016-08-31 08:28 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-31 08:28:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
modified math-once.patch (2.68 KB, patch)
2015-12-17 09:12 EST, Karsten Hopp
no flags Details | Diff

  None (edit)
Description Karsten Hopp 2015-12-17 09:12:41 EST
Created attachment 1106734 [details]
modified math-once.patch

Description of problem:

http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=2993400 shows a lot of truncated file errors. This is similar to https://bugs.python.org/issue24421
and a slightly modified patch fixes that.

Version-Release number of selected component (if applicable):
python3-3.5.1-1.fc24

How reproducible:


Steps to Reproduce:
1. ppc-koji build --scratch f24 python3-3.5.1-1.fc24.src.rpm
2.
3.

Actual results:
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=2993404

Expected results:


Additional info:
Comment 1 Karsten Hopp 2015-12-22 04:53:20 EST
fixed in python3-3.5.1-2.fc24 so that we can proceed on secondary archs, but needs review
Comment 2 Fedora Admin XMLRPC Client 2016-01-29 08:07:28 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Jan Kurik 2016-02-24 10:32:44 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 4 Charalampos Stratakis 2016-08-31 08:28:15 EDT
The issue is fixed upstream since Python 3.5.2 (which is currently in rawhide and soon to be at f25), and the same fix is applied upstream as the downstream patch applied from here.

scratch build from ppc koji that verifies the fix:
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=3658934

Note You need to log in before you can comment on or make changes to this bug.