Bug 1292467 - FTBFS: test.test_venv.EnsurePipTest fails
FTBFS: test.test_venv.EnsurePipTest fails
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: python3 (Show other bugs)
24
powerpc Linux
unspecified Severity high
: ---
: ---
Assigned To: Charalampos Stratakis
Fedora Extras Quality Assurance
:
Depends On: 1292461 1292462
Blocks: PPCTracker 1287556
  Show dependency treegraph
 
Reported: 2015-12-17 09:26 EST by Karsten Hopp
Modified: 2016-09-09 05:34 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-31 08:45:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karsten Hopp 2015-12-17 09:26:41 EST
Description of problem:
self checks on ppc64 fail:
[373/396] test_venv
test_defaults (test.test_venv.BasicTest) ... ok
test_executable (test.test_venv.BasicTest) ... ok
test_executable_symlinks (test.test_venv.BasicTest) ... ok
test_isolation (test.test_venv.BasicTest) ... ok
test_overwrite_existing (test.test_venv.BasicTest) ... ok
test_prefixes (test.test_venv.BasicTest) ... ok
test_symlinking (test.test_venv.BasicTest) ... ok
test_unoverwritable_fails (test.test_venv.BasicTest) ... ok
test_upgrade (test.test_venv.BasicTest) ... ok
test_devnull_exists_and_is_empty (test.test_venv.EnsurePipTest) ... ok
test_explicit_no_pip (test.test_venv.EnsurePipTest) ... ok
test_no_pip_by_default (test.test_venv.EnsurePipTest) ... ok
test_with_pip (test.test_venv.EnsurePipTest) ... Got an error:
[SSL: TLSV1_ALERT_UNKNOWN_CA] tlsv1 alert unknown ca (_ssl.c:645)
Got an error:
[SSL: TLSV1_ALERT_UNKNOWN_CA] tlsv1 alert unknown ca (_ssl.c:645)
test test_venv failed
FAIL

======================================================================
FAIL: test_with_pip (test.test_venv.EnsurePipTest)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/builddir/build/BUILD/Python-3.5.1/Lib/test/test_venv.py", line 390, in test_with_pip
    self.assertEqual(err, "")
AssertionError: "The directory '/builddir/.cache/pip/http[204 chars]g.\n" != ''
- The directory '/builddir/.cache/pip/http' or its parent directory is not owned by the current user and the cache has been disabled. Please check the permissions and owner of that directory. If executing pip with sudo, you may want sudo's -H flag.


Version-Release number of selected component (if applicable):
python3-3.5.1-1.fc24
python3-pip-7.1.0-3.fc24

How reproducible:


Steps to Reproduce:
1. ppc-koji build --scratch f24 python3-3.5.1-1.fc24.src.rpm
2.
3.


Additional info:
This error shows up after fixing bug#1292461 and bug#1292462
Comment 1 Karsten Hopp 2015-12-22 04:53:37 EST
fixed in python3-3.5.1-2.fc24 so that we can proceed on secondary archs, but needs review
Comment 2 Fedora Admin XMLRPC Client 2016-01-29 08:07:34 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Jan Kurik 2016-02-24 10:32:51 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 4 Charalampos Stratakis 2016-08-31 08:45:25 EDT
Test passes now successfully without the patch, so it was dropped on rebasing Python to 3.5.2, currently in rawhide (and soon in F25).

build without the patch:
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=3658934
Comment 5 Mike Goodwin 2016-09-08 17:29:56 EDT
Upstream is deprecating `pyvenv` in favor of `python3 -m venv` and it currently doesn't work because there's no ensurepip module. 

Does this ticket address that issue? I intended to file a separate bug but then I saw this and now I'm not so sure. 

https://bugs.python.org/issue27285 - pyvenv is depreacted for 3.6 and they recommend the use of `python3 -m venv` as early as 3.5.1 

FYI, I've also seen this behavior in EPEL - it is also missing ensurepip so not even pyvenv - the alternative is to download the pip bootstrap from PyPa....

All of which defeats the purpose of having virtualenv tools to begin with.

What's the purpose behind not shipping ensurepip?
Comment 6 Charalampos Stratakis 2016-09-09 05:34:02 EDT
(In reply to Mike Goodwin from comment #5)
> Upstream is deprecating `pyvenv` in favor of `python3 -m venv` and it
> currently doesn't work because there's no ensurepip module. 
> 
> Does this ticket address that issue? I intended to file a separate bug but
> then I saw this and now I'm not so sure. 
> 
> https://bugs.python.org/issue27285 - pyvenv is depreacted for 3.6 and they
> recommend the use of `python3 -m venv` as early as 3.5.1 
> 
> FYI, I've also seen this behavior in EPEL - it is also missing ensurepip so
> not even pyvenv - the alternative is to download the pip bootstrap from
> PyPa....
> 
> All of which defeats the purpose of having virtualenv tools to begin with.
> 
> What's the purpose behind not shipping ensurepip?

Ensurepip actually is shipped with python3 and 'python3 -m venv' works at my machine (F24, python3-3.5.1-13.fc24.x86_64). What is the exact issue you are facing?

Note You need to log in before you can comment on or make changes to this bug.