Bug 1292526 - Backport: Support migration of non-HA router to HA and reverse
Backport: Support migration of non-HA router to HA and reverse
Status: CLOSED DUPLICATE of bug 1292527
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
5.0 (RHEL 7)
All Linux
unspecified Severity high
: ---
: 8.0 (Liberty)
Assigned To: lpeer
Ofer Blaut
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-17 12:07 EST by Anderson Kaiser
Modified: 2016-04-26 12:01 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-17 12:12:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anderson Kaiser 2015-12-17 12:07:54 EST
Description of problem:

We are testing the migration from IceHouse to Kilo in our lab.

We tried to migrate our legacy routers (non-HA) to HA following the instructions on: http://docs.openstack.org/networking-guide/migration_legacy_to_L3_HA.html

So we do:
neutron router-update router_id --admin_state_up=False --- works

neutron router-update router_id --ha=True --- Fail with the message:  Cannot update read-only attribute ha

Then we find this bug: https://bugs.launchpad.net/neutron/+bug/1365426 and we apply manually the code on our envinronment and this works.

Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:

neutron router-update router_id --admin_state_up=False --- works

neutron router-update router_id --ha=True --- Fail with the message:  Cannot update read-only attribute ha

Actual results:

Router attibutes can not be changed.

Expected results:

Routers should be able to migrate or change the attribute

Additional info:

Customer wants to know if this bug will be backported. He already tested it in non production and the proposed patch worked as expected.
Comment 2 Anderson Kaiser 2015-12-17 12:12:07 EST

*** This bug has been marked as a duplicate of bug 1292527 ***

Note You need to log in before you can comment on or make changes to this bug.