Bug 1292527 - Backport: Support migration of non-HA router to HA and reverse
Backport: Support migration of non-HA router to HA and reverse
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-neutron (Show other bugs)
7.0 (Kilo)
All Linux
unspecified Severity high
: ---
: 7.0 (Kilo)
Assigned To: John Schwarz
Toni Freger
: ZStream
: 1292526 (view as bug list)
Depends On:
Blocks: 1295690
  Show dependency treegraph
 
Reported: 2015-12-17 12:08 EST by Anderson Kaiser
Modified: 2016-06-22 15:16 EDT (History)
10 users (show)

See Also:
Fixed In Version: openstack-neutron-2015.1.2-10.el7ost
Doc Type: Enhancement
Doc Text:
With this update, legacy routers can now be migrated to an HA router, and vice versa. This allows users to migrate legacy routers to HA routers. To do so, users must unschedule the router from the existing agents, change the 'ha' attribute to 'True', then re-schedule it. Migration from an HA router to a non-HA router is also possible. Users can use the following commands to migrate a router to and from HA: neutron router-update --admin-state-up=False <ROUTER> neutron router-update --ha=True/False <ROUTER> neutron router-update --admin-state-up=True <ROUTER>
Story Points: ---
Clone Of:
: 1295690 (view as bug list)
Environment:
Last Closed: 2016-06-22 15:16:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1365426 None None None 2015-12-17 12:10 EST
OpenStack gerrit 233646 None None None 2015-12-17 23:38 EST
OpenStack gerrit 262740 None None None 2016-01-04 07:55 EST

  None (edit)
Description Anderson Kaiser 2015-12-17 12:08:40 EST
Description of problem:

We are testing the migration from IceHouse to Kilo in our lab.

We tried to migrate our legacy routers (non-HA) to HA following the instructions on: http://docs.openstack.org/networking-guide/migration_legacy_to_L3_HA.html

So we do:
neutron router-update router_id --admin_state_up=False --- works

neutron router-update router_id --ha=True --- Fail with the message:  Cannot update read-only attribute ha

Then we find this bug: https://bugs.launchpad.net/neutron/+bug/1365426 and we apply manually the code on our envinronment and this works.

Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:

neutron router-update router_id --admin_state_up=False --- works

neutron router-update router_id --ha=True --- Fail with the message:  Cannot update read-only attribute ha

Actual results:

Router attibutes can not be changed.

Expected results:

Routers should be able to migrate or change the attribute

Additional info:

Customer wants to know if this bug will be backported. He already tested it in non production and the proposed patch worked as expected.
Comment 2 Anderson Kaiser 2015-12-17 12:12:07 EST
*** Bug 1292526 has been marked as a duplicate of this bug. ***
Comment 3 Assaf Muller 2015-12-17 23:35:43 EST
I'm assuming you expect this backport to OSP 7, seeing as HA routers didn't exist in OSP 5?
Comment 9 Mike McCune 2016-03-28 18:49:28 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 10 Assaf Muller 2016-06-04 15:57:20 EDT
The bug was flipped back to POST by accident in March. The bug should be in modified - The fix exists in the package in the 'Fixed in version' field and the doc text is set to '?'.
Comment 12 Toni Freger 2016-06-22 06:40:53 EDT
Tested on openstack-neutron-2015.1.2-15.el7ost.noarch
openstack-neutron-openvswitch-2015.1.2-15.el7ost.noarch

Steps to reproduce:

1. neutron router-update router_id --admin_state_up=False 
2. neutron router-update router_id --ha=True 
3. neutron router-update router_id --admin_state_up=True
4. Tested that router namespaces created within two network nodes correctly 
5. boot vm attach to the same network as router and start continuous ping, towards the router - ping replied successfully. 
6. neutron router-update router_id --admin_state_up=False 
7. neutron router-update router_id --ha=False 
8. neutron router-update router_id --admin_state_up=True
9. Ping continue to work when router's namspaces don't part of the Ha-network anymore
Comment 14 errata-xmlrpc 2016-06-22 15:16:48 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1287

Note You need to log in before you can comment on or make changes to this bug.