Bug 1292558 - gnome-settings-daemon 3.19.3-1 kills gnome-shell login
gnome-settings-daemon 3.19.3-1 kills gnome-shell login
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
: 1292014 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-17 14:07 EST by Valdis Kletnieks
Modified: 2016-09-22 09:36 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-22 09:36:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Valdis Kletnieks 2015-12-17 14:07:17 EST
Description of problem:
With gnome-settings-daemon-3.19.3-1.fc24.x86_64 installed, the gdm login screen never shows up, instead gnome-shell dies with this in dmesg:

[ 2090.490726] traps: gnome-shell[6768] trap int3 ip:7f18a0986a8b sp:7ffd066f2d90 error:0
[ 2093.893838] traps: gnome-shell[6880] trap int3 ip:7fb6f31e8a8b sp:7ffdd3037970 error:0
[ 2096.864005] traps: gnome-shell[6946] trap int3 ip:7f7f5da6aa8b sp:7ffda0d28bf0 error:0
[ 2099.783053] traps: gnome-shell[7012] trap int3 ip:7f057fa69a8b sp:7fff7856e260 error:0
[ 2102.753312] traps: gnome-shell[7078] trap int3 ip:7f4684310a8b sp:7ffe4d181750 error:0
[ 2106.284095] traps: gnome-shell[7191] trap int3 ip:7f65affb6a8b sp:7ffdbc32dd30 error:0

Unfortunately, ASLR means only the 'a8b' i the ip: has any persistent meaning.

Re-installing 3.18.2-1 made gnome-shell happy again.

Sorry, didn't get a core file of it.  Can probably do so if needed to debug this.


Version-Release number of selected component (if applicable):
gnome-settings-daemon-3.19.3-1.fc24.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Florian Müllner 2015-12-18 10:10:12 EST
Probably not gnome-settings-daemon, but gsettings-desktop-schemas that changed a settings key in 3.19.3. gnome-shell 3.19.2 still uses the old settings key, which is a fatal error (unfortunately gnome-shell 3.19.3 was delayed due to an outstanding release of one of its dependencies, so it wasn't updated with gsettings-desktop-schemas/control-center).
The builds should be in the next rawhide compose
Comment 2 Valdis Kletnieks 2015-12-18 11:18:39 EST
"D'Oh!" -- H. Simpson :)

Yeah, I had to roll gsettings-desktop-schemas and 4 other RPMs back to go back to the previous gnome-settings-daemon, and picked the wrong 1 out of 6. :)

Will report back once all the builds are updated, hopefully with a "yes it's fixed"....
Comment 3 Florian Müllner 2015-12-18 14:33:02 EST
(In reply to Valdis Kletnieks from comment #2)
> Will report back once all the builds are updated

If you don't want to wait, you can grab the latest rawhide builds for clutter, mutter and gnome-shell from koji.fedoraproject.org (and re-update the downgraded packages of course)
Comment 4 Florian Müllner 2015-12-18 20:51:54 EST
*** Bug 1292014 has been marked as a duplicate of this bug. ***
Comment 5 Jan Kurik 2016-02-24 09:09:19 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 6 Bastien Nocera 2016-09-22 09:36:56 EDT
This was fixed before F24 got released.

Note You need to log in before you can comment on or make changes to this bug.