Bug 1292574 - UI: Download file from saved report is named after the current date rather than after the report saved date [NEEDINFO]
UI: Download file from saved report is named after the current date rather th...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.3.0
Unspecified Unspecified
medium Severity low
: GA
: 5.5.2
Assigned To: Harpreet Kataria
Milan Falešník
: ZStream
Depends On: 1196377 1292579 1306699
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-17 15:16 EST by John Prause
Modified: 2016-02-11 10:42 EST (History)
12 users (show)

See Also:
Fixed In Version: 5.5.2.1
Doc Type: Bug Fix
Doc Text:
In the previous version of CloudForms Management Engine, a saved report file name would include the current date when downloaded, rather then the date on which the report was saved. This was because the time stamp in the report footer, from which the file name was derived, was set to the current time when downloading. This bug was fixed by changing the time stamp in the report footer to the time when the report was last run. Saved report file names now include the report saved date upon downloading in the new version of CloudForms Management Engine.
Story Points: ---
Clone Of: 1196377
Environment:
Last Closed: 2016-02-10 10:29:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
cfme-bot: needinfo?


Attachments (Terms of Use)

  None (edit)
Comment 2 Harpreet Kataria 2016-01-07 13:51:01 EST
https://github.com/ManageIQ/manageiq/pull/6087
Comment 3 CFME Bot 2016-01-07 16:56:35 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/95d3995bb566be138207dd9c97b7d06e992e083d

commit 95d3995bb566be138207dd9c97b7d06e992e083d
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Thu Jan 7 13:48:51 2016 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Thu Jan 7 14:57:01 2016 -0500

    Appended time to filename for downloadable saved reports.
    
    Fixed Date/Time displayed in the footer in text version of downloadable  saved reports to show time of when the saved report was last run instead of displaying time when it was downloaded.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1196377
    https://bugzilla.redhat.com/show_bug.cgi?id=1292579
    https://bugzilla.redhat.com/show_bug.cgi?id=1292574

 app/controllers/application_controller.rb | 2 +-
 app/models/miq_report_result.rb           | 4 ++++
 lib/report_formatter/text.rb              | 4 +++-
 3 files changed, 8 insertions(+), 2 deletions(-)
Comment 5 CFME Bot 2016-01-07 18:47:55 EST
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=44d369fb429201d61292b75160aa2652d53d9d85

commit 44d369fb429201d61292b75160aa2652d53d9d85
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Thu Jan 7 17:14:21 2016 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Thu Jan 7 17:14:21 2016 -0500

    Appended time to filename for downloadable saved reports.
    
    Fixed Date/Time displayed in the footer in text version of downloadable  saved reports to show time of when the saved report was last run instead of displaying time when it was downloaded.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1196377
    https://bugzilla.redhat.com/show_bug.cgi?id=1292579
    https://bugzilla.redhat.com/show_bug.cgi?id=1292574
    (cherry picked from commit 95d3995)

 vmdb/app/controllers/application_controller.rb | 2 +-
 vmdb/app/models/miq_report_result.rb           | 4 ++++
 vmdb/lib/report_formatter/text.rb              | 4 +++-
 3 files changed, 8 insertions(+), 2 deletions(-)
Comment 6 CFME Bot 2016-01-07 18:48:12 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=4361d61f8154565bf1ea64d76f4331bfec04f58d

commit 4361d61f8154565bf1ea64d76f4331bfec04f58d
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Thu Jan 7 13:48:51 2016 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Thu Jan 7 17:11:38 2016 -0500

    Appended time to filename for downloadable saved reports.
    
    Fixed Date/Time displayed in the footer in text version of downloadable  saved reports to show time of when the saved report was last run instead of displaying time when it was downloaded.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1196377
    https://bugzilla.redhat.com/show_bug.cgi?id=1292579
    https://bugzilla.redhat.com/show_bug.cgi?id=1292574
    (cherry picked from commit 95d3995)

 app/controllers/application_controller.rb | 2 +-
 app/models/miq_report_result.rb           | 4 ++++
 lib/report_formatter/text.rb              | 4 +++-
 3 files changed, 8 insertions(+), 2 deletions(-)
Comment 7 CFME Bot 2016-01-07 18:48:29 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=c160de86eafba1733c5c8235a15a7fc759188003

commit c160de86eafba1733c5c8235a15a7fc759188003
Merge: 3074a1d 4361d61
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Thu Jan 7 18:41:44 2016 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Thu Jan 7 18:41:44 2016 -0500

    Merge branch '55z_pr_6087' into '5.5.z'
    
    Appended time to filename for downloadable saved reports.
    
    Fixed Date/Time displayed in the footer in text version of downloadable  saved reports to show time of when the saved report was last run instead of displaying time when it was downloaded.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1196377
    https://bugzilla.redhat.com/show_bug.cgi?id=1292579
    https://bugzilla.redhat.com/show_bug.cgi?id=1292574
    (cherry picked from commit 95d3995)
    
    @dclarizi please review, clean 5.5.z cherry-pick for https://github.com/ManageIQ/manageiq/pull/6087
    
    See merge request !684

 app/controllers/application_controller.rb | 2 +-
 app/models/miq_report_result.rb           | 4 ++++
 lib/report_formatter/text.rb              | 4 +++-
 3 files changed, 8 insertions(+), 2 deletions(-)
Comment 8 CFME Bot 2016-01-07 18:48:46 EST
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=041e41dffed72123fe94e1906911ba670358fab9

commit 041e41dffed72123fe94e1906911ba670358fab9
Merge: 1972945 44d369f
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Thu Jan 7 18:42:16 2016 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Thu Jan 7 18:42:16 2016 -0500

    Merge branch '54z_pr_6087' into '5.4.z'
    
    Appended time to filename for downloadable saved reports.
    
    Fixed Date/Time displayed in the footer in text version of downloadable  saved reports to show time of when the saved report was last run instead of displaying time when it was downloaded.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1196377
    https://bugzilla.redhat.com/show_bug.cgi?id=1292579
    https://bugzilla.redhat.com/show_bug.cgi?id=1292574
    (cherry picked from commit 95d3995)
    
    @dclarizi please review, clean 5.4.z cherry-pick for https://github.com/ManageIQ/manageiq/pull/6087
    
    See merge request !685

 vmdb/app/controllers/application_controller.rb | 2 +-
 vmdb/app/models/miq_report_result.rb           | 4 ++++
 vmdb/lib/report_formatter/text.rb              | 4 +++-
 3 files changed, 8 insertions(+), 2 deletions(-)
Comment 17 errata-xmlrpc 2016-02-10 10:29:31 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0159
Comment 19 CFME Bot 2016-02-10 15:16:29 EST
Detected commit referencing this ticket while ticket status is CLOSED.
Comment 20 CFME Bot 2016-02-11 10:21:33 EST
Detected commit referencing this ticket while ticket status is CLOSED.

Note You need to log in before you can comment on or make changes to this bug.