Bug 1292579 - UI: Download file from saved report is named after the current date rather than after the report saved date
UI: Download file from saved report is named after the current date rather th...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.3.0
Unspecified Unspecified
medium Severity low
: GA
: 5.4.5
Assigned To: Harpreet Kataria
Pete Savage
report
: ZStream
: 1306810 (view as bug list)
Depends On: 1196377 1306181 1306699 1306809 1306810
Blocks: 1292574
  Show dependency treegraph
 
Reported: 2015-12-17 15:18 EST by John Prause
Modified: 2016-03-29 10:16 EDT (History)
14 users (show)

See Also:
Fixed In Version: 5.4.5.2
Doc Type: Bug Fix
Doc Text:
In the previous version of CloudForms Management Engine, when downloading a saved report, the downloaded file was being named after the current date rather than after the report saved date. This patch fixes the date/time displayed in the footer in text version of downloadable saved reports to show time of when the saved report was last run instead of displaying time when it was downloaded, and the issue in now resolved.
Story Points: ---
Clone Of: 1196377
Environment:
Last Closed: 2016-03-29 10:16:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Harpreet Kataria 2016-01-07 13:51:10 EST
https://github.com/ManageIQ/manageiq/pull/6087
Comment 3 CFME Bot 2016-01-07 16:56:29 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/95d3995bb566be138207dd9c97b7d06e992e083d

commit 95d3995bb566be138207dd9c97b7d06e992e083d
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Thu Jan 7 13:48:51 2016 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Thu Jan 7 14:57:01 2016 -0500

    Appended time to filename for downloadable saved reports.
    
    Fixed Date/Time displayed in the footer in text version of downloadable  saved reports to show time of when the saved report was last run instead of displaying time when it was downloaded.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1196377
    https://bugzilla.redhat.com/show_bug.cgi?id=1292579
    https://bugzilla.redhat.com/show_bug.cgi?id=1292574

 app/controllers/application_controller.rb | 2 +-
 app/models/miq_report_result.rb           | 4 ++++
 lib/report_formatter/text.rb              | 4 +++-
 3 files changed, 8 insertions(+), 2 deletions(-)
Comment 5 CFME Bot 2016-01-07 18:47:50 EST
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=44d369fb429201d61292b75160aa2652d53d9d85

commit 44d369fb429201d61292b75160aa2652d53d9d85
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Thu Jan 7 17:14:21 2016 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Thu Jan 7 17:14:21 2016 -0500

    Appended time to filename for downloadable saved reports.
    
    Fixed Date/Time displayed in the footer in text version of downloadable  saved reports to show time of when the saved report was last run instead of displaying time when it was downloaded.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1196377
    https://bugzilla.redhat.com/show_bug.cgi?id=1292579
    https://bugzilla.redhat.com/show_bug.cgi?id=1292574
    (cherry picked from commit 95d3995)

 vmdb/app/controllers/application_controller.rb | 2 +-
 vmdb/app/models/miq_report_result.rb           | 4 ++++
 vmdb/lib/report_formatter/text.rb              | 4 +++-
 3 files changed, 8 insertions(+), 2 deletions(-)
Comment 6 CFME Bot 2016-01-07 18:48:06 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=4361d61f8154565bf1ea64d76f4331bfec04f58d

commit 4361d61f8154565bf1ea64d76f4331bfec04f58d
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Thu Jan 7 13:48:51 2016 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Thu Jan 7 17:11:38 2016 -0500

    Appended time to filename for downloadable saved reports.
    
    Fixed Date/Time displayed in the footer in text version of downloadable  saved reports to show time of when the saved report was last run instead of displaying time when it was downloaded.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1196377
    https://bugzilla.redhat.com/show_bug.cgi?id=1292579
    https://bugzilla.redhat.com/show_bug.cgi?id=1292574
    (cherry picked from commit 95d3995)

 app/controllers/application_controller.rb | 2 +-
 app/models/miq_report_result.rb           | 4 ++++
 lib/report_formatter/text.rb              | 4 +++-
 3 files changed, 8 insertions(+), 2 deletions(-)
Comment 7 CFME Bot 2016-01-07 18:48:24 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=c160de86eafba1733c5c8235a15a7fc759188003

commit c160de86eafba1733c5c8235a15a7fc759188003
Merge: 3074a1d 4361d61
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Thu Jan 7 18:41:44 2016 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Thu Jan 7 18:41:44 2016 -0500

    Merge branch '55z_pr_6087' into '5.5.z'
    
    Appended time to filename for downloadable saved reports.
    
    Fixed Date/Time displayed in the footer in text version of downloadable  saved reports to show time of when the saved report was last run instead of displaying time when it was downloaded.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1196377
    https://bugzilla.redhat.com/show_bug.cgi?id=1292579
    https://bugzilla.redhat.com/show_bug.cgi?id=1292574
    (cherry picked from commit 95d3995)
    
    @dclarizi please review, clean 5.5.z cherry-pick for https://github.com/ManageIQ/manageiq/pull/6087
    
    See merge request !684

 app/controllers/application_controller.rb | 2 +-
 app/models/miq_report_result.rb           | 4 ++++
 lib/report_formatter/text.rb              | 4 +++-
 3 files changed, 8 insertions(+), 2 deletions(-)
Comment 8 CFME Bot 2016-01-07 18:48:41 EST
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=041e41dffed72123fe94e1906911ba670358fab9

commit 041e41dffed72123fe94e1906911ba670358fab9
Merge: 1972945 44d369f
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Thu Jan 7 18:42:16 2016 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Thu Jan 7 18:42:16 2016 -0500

    Merge branch '54z_pr_6087' into '5.4.z'
    
    Appended time to filename for downloadable saved reports.
    
    Fixed Date/Time displayed in the footer in text version of downloadable  saved reports to show time of when the saved report was last run instead of displaying time when it was downloaded.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1196377
    https://bugzilla.redhat.com/show_bug.cgi?id=1292579
    https://bugzilla.redhat.com/show_bug.cgi?id=1292574
    (cherry picked from commit 95d3995)
    
    @dclarizi please review, clean 5.4.z cherry-pick for https://github.com/ManageIQ/manageiq/pull/6087
    
    See merge request !685

 vmdb/app/controllers/application_controller.rb | 2 +-
 vmdb/app/models/miq_report_result.rb           | 4 ++++
 vmdb/lib/report_formatter/text.rb              | 4 +++-
 3 files changed, 8 insertions(+), 2 deletions(-)
Comment 13 CFME Bot 2016-02-11 18:55:44 EST
New commit detected on ManageIQ/manageiq/master:
https://github.com/ManageIQ/manageiq/commit/70e112d0edaaada97caadfcecf7bfaa3ca2f80c4

commit 70e112d0edaaada97caadfcecf7bfaa3ca2f80c4
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Wed Feb 10 15:01:45 2016 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Thu Feb 11 10:53:32 2016 -0500

    Fixed an issue where rpt_options could be nil for some OOTB reports.
    
    Downloading txt reports can fail on merge! if rpt_options is nil
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1196377
    https://bugzilla.redhat.com/show_bug.cgi?id=1306699
    https://bugzilla.redhat.com/show_bug.cgi?id=1292579

 app/models/miq_report_result.rb | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)
Comment 14 CFME Bot 2016-02-12 09:58:50 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=cbb2d5fa0ffe21d7cf120ab5fad53ec2de6adb48

commit cbb2d5fa0ffe21d7cf120ab5fad53ec2de6adb48
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Wed Feb 10 15:01:45 2016 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Fri Feb 12 09:11:09 2016 -0500

    Fixed an issue where rpt_options could be nil for some OOTB reports.
    
    Downloading txt reports can fail on merge! if rpt_options is nil
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1196377
    https://bugzilla.redhat.com/show_bug.cgi?id=1306699
    https://bugzilla.redhat.com/show_bug.cgi?id=1292579
    (cherry picked from commit 70e112d)

 app/models/miq_report_result.rb | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)
Comment 15 CFME Bot 2016-02-12 09:59:07 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=8355600203c0e5863b1b655457597e11a9c38a09

commit 8355600203c0e5863b1b655457597e11a9c38a09
Merge: c2694eb cbb2d5f
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Fri Feb 12 09:54:24 2016 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Fri Feb 12 09:54:24 2016 -0500

    Merge branch '55z_pr_6602' into '5.5.z'
    
    Fixed an issue where rpt_options could be nil for some OOTB reports.
    
    Downloading txt reports can fail on merge! if rpt_options is nil
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1196377
    https://bugzilla.redhat.com/show_bug.cgi?id=1306699
    https://bugzilla.redhat.com/show_bug.cgi?id=1292579
    (cherry picked from commit 70e112d)
    
    @dclarizi please review, clean cherry-pick for https://github.com/ManageIQ/manageiq/pull/6602
    
    See merge request !786

 app/models/miq_report_result.rb | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)
Comment 16 Yuri Rudman 2016-02-12 10:57:44 EST
*** Bug 1306810 has been marked as a duplicate of this bug. ***
Comment 18 CFME Bot 2016-02-19 10:25:06 EST
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=7665a7c4e5f2cb465516da3aeb60f6117ffc36d9

commit 7665a7c4e5f2cb465516da3aeb60f6117ffc36d9
Merge: 26e38bc a1f3a85
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Fri Feb 19 10:06:43 2016 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Fri Feb 19 10:06:43 2016 -0500

    Merge branch '54z_pr_6602' into '5.4.z'
    
    Fixed an issue where rpt_options could be nil for some OOTB reports.
    
    Downloading txt reports can fail on merge! if rpt_options is nil
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1196377
    https://bugzilla.redhat.com/show_bug.cgi?id=1306699
    https://bugzilla.redhat.com/show_bug.cgi?id=1292579
    (cherry picked from commit 70e112d)
    
    @dclarizi please review, clean 5.4.z cherry-pick for https://github.com/ManageIQ/manageiq/pull/6602
    
    See merge request !787

 vmdb/app/models/miq_report_result.rb | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)
Comment 19 CFME Bot 2016-02-19 10:25:12 EST
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=a1f3a85ef5a5905fd0b5a799c8b513fe262c7950

commit a1f3a85ef5a5905fd0b5a799c8b513fe262c7950
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Fri Feb 12 09:14:21 2016 -0500
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Fri Feb 12 09:14:21 2016 -0500

    Fixed an issue where rpt_options could be nil for some OOTB reports.
    
    Downloading txt reports can fail on merge! if rpt_options is nil
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1196377
    https://bugzilla.redhat.com/show_bug.cgi?id=1306699
    https://bugzilla.redhat.com/show_bug.cgi?id=1292579
    (cherry picked from commit 70e112d)

 vmdb/app/models/miq_report_result.rb | 5 ++++-
 1 file changed, 4 insertions(+), 1 deletion(-)
Comment 21 Pete Savage 2016-03-22 03:59:40 EDT
Failed in 5.4.5.2

A report that I ran yesterday, and tried to download today was named

VMs with Volume Free Space _= 75% (sorted by Datastore)_20160322_075740.pdf
Comment 22 Harpreet Kataria 2016-03-22 09:39:41 EDT
Pete,

that file name looks correct to me, if you look at screenshot in the PR it shows file name appended by date of download and time. https://github.com/ManageIQ/manageiq/pull/6087

Can you please elaborate what were you expecting file name to be.

Thanks,
~Harpreet.
Comment 24 Harpreet Kataria 2016-03-22 13:41:55 EDT
Pete,

Can you look at my comment #21 and reply, file name looks correct to me.

Thanks,
~Harpreet
Comment 27 errata-xmlrpc 2016-03-29 10:16:05 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0171.html

Note You need to log in before you can comment on or make changes to this bug.