Bug 1292761 - Add support for proxy-url libgovirt property
Add support for proxy-url libgovirt property
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-viewer (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Virt Viewer Maint
Virtualization Bugs
:
Depends On: 1297830
Blocks: 1295396
  Show dependency treegraph
 
Reported: 2015-12-18 04:54 EST by Christophe Fergeau
Modified: 2016-11-03 21:13 EDT (History)
8 users (show)

See Also:
Fixed In Version: virt-viewer-2.0-7.el7
Doc Type: Bug Fix
Doc Text:
Cause: remote-viewer did not take into account proxy information returned through RHEV REST API Consequence: when using ovirt:// , it was not possible to connect to VMs behind a proxy Fix: get proxy information from RHEV REST API Result: it's possible to connect to VMs behind a proxy when using ovirt:// URIs
Story Points: ---
Clone Of:
: 1292765 (view as bug list)
Environment:
Last Closed: 2016-11-03 21:13:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2229 normal SHIPPED_LIVE virt-viewer, libgovirt, spice-gtk, and usbredir bug fix and enhancement update 2016-11-03 09:26:58 EDT

  None (edit)
Description Christophe Fergeau 2015-12-18 04:54:25 EST
https://git.fedorahosted.org/cgit/virt-viewer.git/commit/?id=f9577b9197b737be722cfd5632b6077ce6b041ff

Without this commit, foreign menu will not work when the oVirt VM is behind a firewall.
Comment 3 xiaodwan 2016-04-19 06:41:33 EDT
I can reproduce it.
# rpm -q libgovirt virt-viewer
libgovirt-0.3.3-1.el7.x86_64
virt-viewer-2.0-6.el7.x86_64

Steps:
1. Setup an env and make sure you can connect to ovirt directly but can't connect to vm directly.
2. configure a proxy, make sure you can connect to vm by the proxy.
3. get the ca.crt file from ovirt.
# wget https://ibm-x3250m5-03.qe.lab.eng.nay.redhat.com/ca.crt
4. connect the vm by ovirt.
# remote-viewer --ovirt-ca-file=ca.crt ovirt://ibm-x3250m5-03.qe.lab.eng.nay.redhat.com/$vm

Result:
Can see remote-viewer window pops up and "change cd" menu displays but connect to the vm fail.

Updated virt-viewer to version virt-viewer-2.0-7.el7.x86_64 and verified it again.

can see the foreign menu and can connect to the vm successfully.

So move the bug to VERIFIED.
Comment 5 errata-xmlrpc 2016-11-03 21:13:29 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2229.html

Note You need to log in before you can comment on or make changes to this bug.