Bug 1292765 - Add support for proxy-url libgovirt property
Add support for proxy-url libgovirt property
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-viewer (Show other bugs)
6.7
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Virt Viewer Maint
Virtualization Bugs
:
Depends On: 1292754
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-18 05:00 EST by Christophe Fergeau
Modified: 2016-05-10 17:20 EDT (History)
12 users (show)

See Also:
Fixed In Version: virt-viewer-2.0-9.el6
Doc Type: Bug Fix
Doc Text:
Cause: remote-viewer did not take into account proxy information returned through RHEV REST API Consequence: when using ovirt:// , it was not possible to connect to VMs behind a proxy Fix: get proxy information from RHEV REST API Result: it's possible to connect to VMs behind a proxy when using ovirt:// URIs
Story Points: ---
Clone Of: 1292761
Environment:
Last Closed: 2016-05-10 17:20:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs for "G_MESSAGES_DEBUG=all remote-viewer --spice-debug console.vv" (31.99 KB, text/plain)
2016-01-05 08:16 EST, xiaodwan
no flags Details
debugging log (22.69 KB, text/plain)
2016-01-06 05:43 EST, xiaodwan
no flags Details

  None (edit)
Description Christophe Fergeau 2015-12-18 05:00:53 EST
+++ This bug was initially created as a clone of Bug #1292761 +++

https://git.fedorahosted.org/cgit/virt-viewer.git/commit/?id=f9577b9197b737be722cfd5632b6077ce6b041ff

Without this commit, foreign menu will not work when the oVirt VM is behind a firewall.
Comment 6 xiaodwan 2016-01-05 08:16 EST
Created attachment 1111838 [details]
logs for "G_MESSAGES_DEBUG=all remote-viewer --spice-debug console.vv"
Comment 10 xiaodwan 2016-01-06 05:43 EST
Created attachment 1112087 [details]
debugging log
Comment 15 Christophe Fergeau 2016-01-07 08:58:46 EST
I made the same confusion as usual, 'proxy-url' will be used when accessing the VM through ovirt://
Setup:
- the ovirt portal can be accessed without a proxy (I'm not sure how to tell libgovirt to use a proxy, maybe it can use the http_proxy environment variable)
- the VM must only be accessible through a proxy
- run remote-viewer ovirt://rhev-portal.example.com/vm-name

expected result: remote-viewer should access the VM named 'vm-name' using the proxy
Comment 16 xiaodwan 2016-01-11 06:04:34 EST
I can reproduce it.
# rpm -q libgovirt virt-viewer
libgovirt-0.3.2-2.el6.x86_64
virt-viewer-2.0-8.el6.x86_64

Steps:
1. Setup an env and make sure you can connect to ovirt directly but can't connect to vm directly.
2. configure a proxy, make sure you can connect to vm by the proxy.
3. get the ca.crt file from ovirt.
# wget https://ibm-x3250m5-03.qe.lab.eng.nay.redhat.com/ca.crt
4. connect the vm by ovirt.
# remote-viewer --ovirt-ca-file=ca.crt ovirt://ibm-x3250m5-03.qe.lab.eng.nay.redhat.com/$vm

Result:
Can see remote-viewer window pops up and "change cd" menu displays but connect to the vm fail.

Updated virt-viewer to version virt-viewer-2.0-12.el6.x86_64 and verified it again.

can see the foreign menu and can connect to the vm successfully.

So move the bug to verified.
Comment 18 errata-xmlrpc 2016-05-10 17:20:45 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0832.html

Note You need to log in before you can comment on or make changes to this bug.