Bug 1292788 - [virtio-win][viostor] Cannot install viostor driver on win7-64&win2008-64&win2008R2
Summary: [virtio-win][viostor] Cannot install viostor driver on win7-64&win2008-64&win...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.3
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: ---
Assignee: Vadim Rozenfeld
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-12-18 10:54 UTC by Yu Wang
Modified: 2016-11-04 08:49 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
NO_DOCS
Clone Of:
Environment:
Last Closed: 2016-11-04 08:49:30 UTC
Target Upstream Version:


Attachments (Terms of Use)
driver_install_error (60.91 KB, image/png)
2015-12-18 10:54 UTC, Yu Wang
no flags Details
yelloow_!_error (69.22 KB, image/png)
2015-12-18 10:55 UTC, Yu Wang
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2609 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2016-11-03 15:27:12 UTC

Description Yu Wang 2015-12-18 10:54:10 UTC
Created attachment 1107073 [details]
driver_install_error

Description of problem:
Cannot install vioscsi driver on win7-64&win2008-64&win2008R2

Version-Release number of selected component (if applicable):
kernel-3.10.0-335.el7.x86_64
qemu-kvm-rhev-2.3.0-31.el7.x86_64
virtio-win-prewhql-112

How reproducible:
100%

Steps to Reproduce:
1./usr/libexec/qemu-kvm -name 112BLKWIN732IVU -enable-kvm -m 2G -smp 2 -uuid 2195975f-db0b-4cee-90d3-ae0399fab204 -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/tmp/112BLKWIN732IVU,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=112BLKWIN732IVU,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=en_windows_7_ultimate_with_sp1_x86_dvd_u_677460.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=112BLKWIN732IVU.vfd,if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=00:52:29:0a:30:f9,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0 -vnc 0.0.0.0:0 -vga cirrus -object iothread,id=thread0 -drive file=112BLKWIN732IVU_test.raw,if=none,id=drive-virtio-disk0,format=raw,serial=mike_cao,cache=none -device pci-bridge,id=bridge1,chassis_nr=1,bus=pci.0 -device virtio-blk-pci,iothread=thread0,scsi=off,bus=bridge1,addr=0x7,drive=drive-virtio-disk0,id=virtio-disk0 -monitor stdio

2.install viostor driver


Actual results:
occured driver while install

Expected results:
install succesfully

Additional info:
After install, the driver shows yellow ! in device manager , then reboot the guest,  it will boot the startup repair, cannot boot to the guest anymore

Comment 1 Yu Wang 2015-12-18 10:55:23 UTC
Created attachment 1107074 [details]
yelloow_!_error

Comment 4 lijin 2015-12-18 13:13:24 UTC
duplicate of bug1248977,please check https://bugzilla.redhat.com/show_bug.cgi?id=1248977#c9

*** This bug has been marked as a duplicate of bug 1248977 ***

Comment 7 lijin 2016-02-04 05:02:53 UTC
win2008R2 still hit this issue with build 113

Comment 8 lijin 2016-02-17 08:33:30 UTC
set TestBlocker keywords due to it block win7-64/win2008-64/win2008R2 guests' driver test.

Comment 9 Yu Wang 2016-03-04 07:08:53 UTC
win7-64 still hit this issue with build 114

error code 52

Comment 10 Vadim Rozenfeld 2016-03-07 21:25:45 UTC
(In reply to wangyu from comment #9)
> win7-64 still hit this issue with build 114
> 
> error code 52

could you please share the setupapi.dev.log file?

Thanks,
Vadim.

Comment 14 Vadim Rozenfeld 2016-03-18 03:15:46 UTC
Can we please give a try to buikld 115 available at http://download.devel.redhat.com/brewroot/packages/virtio-win-prewhql/0.1/115/win/virtio-win-prewhql-0.1.zip

Thanks,
Vadim.

Comment 15 Peixiu Hou 2016-03-18 08:53:44 UTC
Hello Vadim,

win7-64&win2008R2&win2008-64 still hit this issue with build 115.


Thanks~~
Peixiu Hou

Comment 16 Peixiu Hou 2016-03-18 09:21:47 UTC
cancel needinfo

Comment 17 Yu Wang 2016-03-28 06:05:27 UTC
Reproduced this issue on virtio-win-prewhql-115
Verified this issue on virtio-win-prewhql-116

Verified guest os :
*win7-64
*win2008-64 
*win2008R2.

Verified driver

*viorng
*balloon
*vioser
*pvpanic
*netkvm
*viostor
*vioscsi

steps same as comment#0

on build 116,driver can all successfully installed 
Above all, bug has been fixed, fix version virtio-win-prewhql-116.

Thanks for your great support!:)

BR
wyu

Comment 18 Yu Wang 2016-04-11 03:23:45 UTC
According comment#17, change status to verified.

Comment 21 errata-xmlrpc 2016-11-04 08:49:30 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2609.html


Note You need to log in before you can comment on or make changes to this bug.