Bug 1248977 - [virtio-win][vioscsi] Cannot install vioscsi driver on win7-32&win2008-32
Summary: [virtio-win][vioscsi] Cannot install vioscsi driver on win7-32&win2008-32
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.2
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: ---
Assignee: Vadim Rozenfeld
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1288337
TreeView+ depends on / blocked
 
Reported: 2015-07-31 09:10 UTC by Yu Wang
Modified: 2016-11-04 08:48 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
NO_DOCS
Clone Of:
Environment:
Last Closed: 2016-11-04 08:48:28 UTC
Target Upstream Version:


Attachments (Terms of Use)
win2008-64 scsi driver install failed (64.84 KB, image/png)
2015-12-17 05:14 UTC, lijin
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2609 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2016-11-03 15:27:12 UTC

Description Yu Wang 2015-07-31 09:10:21 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:

100%

Steps to Reproduce:
1.Run command:
/usr/libexec/qemu-kvm -name 107SCSWIN732IAX -enable-kvm -m 2G -smp 2 -uuid 5f621787-61f1-47e0-9bf1-6b00d67900b3 -nodefconfig -nodefaults -cpu Nehalem,+fsgsbase -chardev socket,id=charmonitor,path=/tmp/107SCSWIN732IAX,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -drive file=107SCSWIN732IAX,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=en_windows_7_ultimate_with_sp1_x86_dvd_u_677460.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=107SCSWIN732IAX.vfd,if=none,id=drive-fdc0-0-0,format=raw,cache=none -global isa-fdc.driveA=drive-fdc0-0-0 -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device rtl8139,netdev=hostnet0,id=net0,mac=00:52:34:77:60:40,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0 -vnc 0.0.0.0:0 -vga cirrus -device virtio-scsi-pci,id=scsi0,bus=pci.0,addr=0x7,num_queues=2 -drive file=107SCSWIN732IAX_test.raw,if=none,id=drive-scsi-disk0,format=raw,serial=mike_cao,cache=none -device scsi-hd,bus=scsi0.0,drive=drive-scsi-disk0,id=scsi-disk0

2. Install driver for vioscsi with build107

Actual results:

Cannot install sucessfully on win7-32

Expected results:
Install sucessfully

Additional info:

It is a regression and test blocker bug. It can be installed on build105

Comment 3 Vadim Rozenfeld 2015-08-01 23:54:47 UTC
Please check with build 108 available at https://brewweb.devel.redhat.com//buildinfo?buildID=450261

Thanks,
Vadim.

Comment 4 lijin 2015-09-11 05:21:42 UTC
change status to verified as 109 scsi whql test all passed,scsi driver can be install correctly.

Comment 5 Vadim Rozenfeld 2015-09-30 06:06:26 UTC
This bug is tightly coupled with https://bugzilla.redhat.com/show_bug.cgi?id=1210166 
Moving it to 7.3 as well.

Comment 7 lijin 2015-12-04 07:07:56 UTC
with latest virtio-win-prewhql-0.1-111,install vioscsi driver in guest,guest will stuck,driver can NOT be installed.
I tried on win2008-64 and win10-32,both hit this issue.

Comment 8 Yu Wang 2015-12-07 03:05:44 UTC
with latest virtio-win-prewhql-0.1-111,install vioser driver in guest,driver can NOT be installed successfully.

It shows error info as follows:

shows "This driver is not digitallyigned" when selected to install the driver
shows "windows found driver software for your device bug encountered an error while attempting to install it" and "the system cannot find the file specified"

I tried on win10-64 and win10-32,both hit this issue.

Comment 9 lijin 2015-12-17 05:14:25 UTC
Created attachment 1106575 [details]
win2008-64 scsi driver install failed

try with virtio-win-prewhql-112:
install scsi driver in win2008-64 still failed(please check the screenshot);
win2008-32,win8.1-32 and win2012 do NOT hit this issue,scsi driver can install correctly

Comment 10 Vadim Rozenfeld 2015-12-17 06:18:44 UTC
(In reply to lijin from comment #9)
> Created attachment 1106575 [details]
> win2008-64 scsi driver install failed
> 
> try with virtio-win-prewhql-112:
> install scsi driver in win2008-64 still failed(please check the screenshot);
> win2008-32,win8.1-32 and win2012 do NOT hit this issue,scsi driver can
> install correctly

Thanks, will try to reproduce it shortly. Could you please confirm that the command line is just the same as in the problem description?

Vadim.

Comment 11 lijin 2015-12-17 08:36:17 UTC
(In reply to Vadim Rozenfeld from comment #10)
> (In reply to lijin from comment #9)
> > Created attachment 1106575 [details]
> > win2008-64 scsi driver install failed
> > 
> > try with virtio-win-prewhql-112:
> > install scsi driver in win2008-64 still failed(please check the screenshot);
> > win2008-32,win8.1-32 and win2012 do NOT hit this issue,scsi driver can
> > install correctly
> 
> Thanks, will try to reproduce it shortly. Could you please confirm that the
> command line is just the same as in the problem description?
> 
> Vadim.

I just add the scsi controller in qemu cli,try with or without mq,both hit this issue:
"-device virtio-scsi-pci,id=scsi0" 
"-device virtio-scsi-pci,id=scsi0,num_queues=2"

full qemu cli:
/usr/libexec/qemu-kvm -M pc -cpu SandyBridge -M pc -enable-kvm -m 2G -smp 2 -nodefconfig -nodefaults -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -drive file=win2008-64.raw,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -vnc 0.0.0.0:1 -vga cirrus -qmp tcp:0:4444,server,nowait -monitor stdio -netdev tap,script=/etc/qemu-ifup,downscript=no,id=hostnet0 -device e1000,netdev=hostnet0,id=net0,mac=00:52:3b:35:00:99 -cdrom /usr/share/virtio-win/virtio-win.iso -drive file=en_windows_server_2008_datacenter_enterprise_standard_sp2_x64_dvd_342336.iso,if=none,id=drive-ide0-0-1,format=raw,cache=none,media=cdrom -device ide-drive,bus=ide.0,unit=1,drive=drive-ide0-0-1,id=ide0-0-1 -device virtio-scsi-pci,id=scsi0,num_queues=2

Comment 12 lijin 2015-12-18 13:13:24 UTC
*** Bug 1292788 has been marked as a duplicate of this bug. ***

Comment 13 lijin 2016-02-04 05:02:23 UTC
win2008R2 still hit this issue with build 113

Comment 14 Yu Wang 2016-03-04 07:09:06 UTC
win7-64 still hit this issue with build 114

error code 52

Comment 15 Vadim Rozenfeld 2016-03-18 03:16:06 UTC
Can we please give a try to buikld 115 available at http://download.devel.redhat.com/brewroot/packages/virtio-win-prewhql/0.1/115/win/virtio-win-prewhql-0.1.zip

Thanks,
Vadim.

Comment 16 Peixiu Hou 2016-03-18 10:02:10 UTC
Hello Vadim,

Verified this issue with build 115, vioscsi driver can be installed successful on win7-32 & win2008-32.

For win2008R2 & win7-64, the vioscsi driver still cannot be normal installed, show error code 52.

For win2008-64, the vioscsi driver still cannot be normal installed, show error code 39.


Best Regards!
Peixiu Hou~

Comment 17 Yu Wang 2016-03-21 09:34:53 UTC
Hi,

Tried with build 116, hit the same issue as comment 16. bug1292788,bug1289406,bug1303806 also hit the same issue.


Thanks
wyu

Comment 18 Yu Wang 2016-03-28 06:05:21 UTC
Comment#17 is wrong, I re-test this with build116, it can be successfully installed. 

Reproduced this issue on virtio-win-prewhql-115
Verified this issue on virtio-win-prewhql-116

Verified guest os :
*win7-64
*win2008-64 
*win2008R2.

Verified driver

*viorng
*balloon
*vioser
*pvpanic
*netkvm
*viostor
*vioscsi

steps same as comment#0

on build 116,driver can all successfully installed 
Above all, bug has been fixed, fix version virtio-win-prewhql-116.

Thanks for your great support!:)

BR
wyu

Comment 20 Yu Wang 2016-05-19 02:03:18 UTC
According comment#18, the bug has been fixed and change status to VERIFIED

Comment 23 errata-xmlrpc 2016-11-04 08:48:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2609.html


Note You need to log in before you can comment on or make changes to this bug.