Bug 1292876 - [abrt] nautilus: wl_proxy_marshal_array_constructor(): nautilus killed by SIGABRT
[abrt] nautilus: wl_proxy_marshal_array_constructor(): nautilus killed by SIG...
Status: CLOSED DUPLICATE of bug 1288287
Product: Fedora
Classification: Fedora
Component: file-roller (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:5b824e2bcde3a4c1bf5fe759d97...
:
Depends On:
Blocks: WaylandRelated
  Show dependency treegraph
 
Reported: 2015-12-18 10:55 EST by Christian Stadelmann
Modified: 2016-08-31 22:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-31 22:03:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (37.90 KB, text/plain)
2015-12-18 10:55 EST, Christian Stadelmann
no flags Details
File: core_backtrace (6.92 KB, text/plain)
2015-12-18 10:55 EST, Christian Stadelmann
no flags Details
File: dso_list (12.56 KB, text/plain)
2015-12-18 10:55 EST, Christian Stadelmann
no flags Details
File: limits (1.29 KB, text/plain)
2015-12-18 10:55 EST, Christian Stadelmann
no flags Details
File: maps (61.63 KB, text/plain)
2015-12-18 10:55 EST, Christian Stadelmann
no flags Details
File: namespaces (85 bytes, text/plain)
2015-12-18 10:55 EST, Christian Stadelmann
no flags Details
File: open_fds (3.41 KB, text/plain)
2015-12-18 10:55 EST, Christian Stadelmann
no flags Details
File: proc_pid_status (1014 bytes, text/plain)
2015-12-18 10:55 EST, Christian Stadelmann
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 763298 None None None 2016-03-08 04:41 EST

  None (edit)
Description Christian Stadelmann 2015-12-18 10:55:12 EST
Version-Release number of selected component:
nautilus-3.18.3-1.fc23

Additional info:
reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        /usr/bin/nautilus --gapplication-service
crash_function: wl_proxy_marshal_array_constructor
executable:     /usr/bin/nautilus
kernel:         4.2.7-300.fc23.x86_64
runlevel:       N 5
type:           CCpp

Truncated backtrace:
Thread no. 1 (6 frames)
 #2 wl_proxy_marshal_array_constructor at src/wayland-client.c:602
 #3 wl_proxy_marshal at src/wayland-client.c:648
 #4 _gdk_wayland_window_drag_begin at /usr/include/wayland-client-protocol.h:999
 #6 gtk_drag_begin_internal at gtkdnd.c:2467
 #7 gtk_drag_begin_with_coordinates at gtkdnd.c:2637
 #8 on_motion_notify_event at gtkplacessidebar.c:1521
Comment 1 Christian Stadelmann 2015-12-18 10:55:17 EST
Created attachment 1107206 [details]
File: backtrace
Comment 2 Christian Stadelmann 2015-12-18 10:55:19 EST
Created attachment 1107207 [details]
File: core_backtrace
Comment 3 Christian Stadelmann 2015-12-18 10:55:21 EST
Created attachment 1107208 [details]
File: dso_list
Comment 4 Christian Stadelmann 2015-12-18 10:55:22 EST
Created attachment 1107209 [details]
File: limits
Comment 5 Christian Stadelmann 2015-12-18 10:55:24 EST
Created attachment 1107210 [details]
File: maps
Comment 6 Christian Stadelmann 2015-12-18 10:55:26 EST
Created attachment 1107211 [details]
File: namespaces
Comment 7 Christian Stadelmann 2015-12-18 10:55:27 EST
Created attachment 1107212 [details]
File: open_fds
Comment 8 Christian Stadelmann 2015-12-18 10:55:28 EST
Created attachment 1107213 [details]
File: proc_pid_status
Comment 9 Christian Stadelmann 2016-01-26 09:09:04 EST
Another user experienced a similar problem:

This issue seems to be reproduced following these steps:
0. use a gnome/wayland session (I don't know whether that is required)
1. open nautilus
2. open an archive with file-roller
3. drag and drop a folder from file-roller into nautilus

What happens:
Nothing. 

What should happen:
copy files

When closing nautilus or file-roller very quickly after 3., nautilus crashes, which lead to this bug report.

reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        /usr/bin/nautilus --gapplication-service
crash_function: wl_proxy_marshal_array_constructor
executable:     /usr/bin/nautilus
kernel:         4.3.4-300.fc23.x86_64
package:        nautilus-3.18.4-1.fc23
reason:         nautilus killed by SIGABRT
runlevel:       N 5
type:           CCpp
Comment 10 Matthias Clasen 2016-08-31 22:03:14 EDT

*** This bug has been marked as a duplicate of bug 1288287 ***

Note You need to log in before you can comment on or make changes to this bug.