Bug 1288287 - [abrt] gedit: wl_proxy_marshal_array_constructor(): gedit killed by SIGABRT
[abrt] gedit: wl_proxy_marshal_array_constructor(): gedit killed by SIGABRT
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gedit (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:482bcebcd0d45f65e183e0bb36e...
:
: 1292876 (view as bug list)
Depends On:
Blocks: WaylandRelated WaylandByDefault
  Show dependency treegraph
 
Reported: 2015-12-03 21:04 EST by Dan Loomis
Modified: 2016-09-12 06:23 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-12 06:23:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (27.21 KB, text/plain)
2015-12-03 21:04 EST, Dan Loomis
no flags Details
File: cgroup (190 bytes, text/plain)
2015-12-03 21:04 EST, Dan Loomis
no flags Details
File: core_backtrace (6.60 KB, text/plain)
2015-12-03 21:04 EST, Dan Loomis
no flags Details
File: dso_list (11.77 KB, text/plain)
2015-12-03 21:04 EST, Dan Loomis
no flags Details
File: environ (855 bytes, text/plain)
2015-12-03 21:04 EST, Dan Loomis
no flags Details
File: limits (1.29 KB, text/plain)
2015-12-03 21:04 EST, Dan Loomis
no flags Details
File: maps (53.45 KB, text/plain)
2015-12-03 21:05 EST, Dan Loomis
no flags Details
File: mountinfo (3.36 KB, text/plain)
2015-12-03 21:05 EST, Dan Loomis
no flags Details
File: namespaces (85 bytes, text/plain)
2015-12-03 21:05 EST, Dan Loomis
no flags Details
File: open_fds (1.64 KB, text/plain)
2015-12-03 21:05 EST, Dan Loomis
no flags Details
File: proc_pid_status (1003 bytes, text/plain)
2015-12-03 21:05 EST, Dan Loomis
no flags Details
File: var_log_messages (288 bytes, text/plain)
2015-12-03 21:05 EST, Dan Loomis
no flags Details

  None (edit)
Description Dan Loomis 2015-12-03 21:04:50 EST
Description of problem:
Opened two files in gedit.   Wanted to look at them side by side.   I tried to drag a tab to a separate Window.   gedit crashed.    Running Wayland if that makes any difference.    

Version-Release number of selected component:
gedit-3.18.2-1.fc23

Additional info:
reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        /usr/bin/gedit --gapplication-service
crash_function: wl_proxy_marshal_array_constructor
executable:     /usr/bin/gedit
global_pid:     3062
kernel:         4.2.6-301.fc23.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #2 wl_proxy_marshal_array_constructor at src/wayland-client.c:602
 #3 wl_proxy_marshal at src/wayland-client.c:648
 #4 wl_data_device_start_drag at /usr/include/wayland-client-protocol.h:999
 #5 _gdk_wayland_window_drag_begin at gdkdnd-wayland.c:378
 #6 gtk_drag_begin_internal at gtkdnd.c:2467
 #7 gtk_drag_begin_with_coordinates at gtkdnd.c:2637
 #8 gtk_notebook_motion_notify at gtknotebook.c:3495
 #9 _gtk_marshal_BOOLEAN__BOXEDv at gtkmarshalers.c:131
 #10 _g_closure_invoke_va at gclosure.c:864
 #13 gtk_widget_event_internal at gtkwidget.c:7692
Comment 1 Dan Loomis 2015-12-03 21:04:53 EST
Created attachment 1102030 [details]
File: backtrace
Comment 2 Dan Loomis 2015-12-03 21:04:54 EST
Created attachment 1102031 [details]
File: cgroup
Comment 3 Dan Loomis 2015-12-03 21:04:55 EST
Created attachment 1102032 [details]
File: core_backtrace
Comment 4 Dan Loomis 2015-12-03 21:04:56 EST
Created attachment 1102033 [details]
File: dso_list
Comment 5 Dan Loomis 2015-12-03 21:04:57 EST
Created attachment 1102034 [details]
File: environ
Comment 6 Dan Loomis 2015-12-03 21:04:58 EST
Created attachment 1102035 [details]
File: limits
Comment 7 Dan Loomis 2015-12-03 21:05:00 EST
Created attachment 1102036 [details]
File: maps
Comment 8 Dan Loomis 2015-12-03 21:05:01 EST
Created attachment 1102037 [details]
File: mountinfo
Comment 9 Dan Loomis 2015-12-03 21:05:02 EST
Created attachment 1102038 [details]
File: namespaces
Comment 10 Dan Loomis 2015-12-03 21:05:03 EST
Created attachment 1102039 [details]
File: open_fds
Comment 11 Dan Loomis 2015-12-03 21:05:04 EST
Created attachment 1102040 [details]
File: proc_pid_status
Comment 12 Dan Loomis 2015-12-03 21:05:05 EST
Created attachment 1102041 [details]
File: var_log_messages
Comment 13 Dan Loomis 2015-12-04 12:07:32 EST
Reproduced easily.   Works as expected on X11.   Added Wayland related
Comment 14 Matthias Clasen 2016-08-31 22:03:14 EDT
*** Bug 1292876 has been marked as a duplicate of this bug. ***
Comment 15 Olivier Fourdan 2016-09-01 03:14:35 EDT
Cannot reproduce using gedit-3.21.90-1.fc25 (but cannot detach the tab either)
Comment 16 Olivier Fourdan 2016-09-01 03:16:16 EDT
Also, opening a new window (with gedit --new-window) and dragging a tab from the first window to the second works as expected.
Comment 17 Christian Stadelmann 2016-09-01 03:38:03 EDT
(In reply to Olivier Fourdan from comment #15)
> Cannot reproduce using gedit-3.21.90-1.fc25 (but cannot detach the tab
> either)

That's weird.

I cannot reproduce this bug either on F25 alpha live images, not even on F24 current gedit versions (3.20.2-1).
Comment 18 Olivier Fourdan 2016-09-01 04:30:33 EDT
(In reply to Christian Stadelmann from comment #17)
> I cannot reproduce this bug either on F25 alpha live images, not even on F24
> current gedit versions (3.20.2-1).

That's good news then! I suspect this might have been a gtk bug instead.
Comment 19 Matthias Clasen 2016-09-12 06:23:40 EDT
ok, I think we should close this then, if it can't be reproduced anymore.

Note You need to log in before you can comment on or make changes to this bug.