Bug 1293152 - New VM dialog offers VM templates from different DCs which are not accessible/usable
New VM dialog offers VM templates from different DCs which are not accessible...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.6.0
Unspecified Unspecified
high Severity high
: ovirt-3.6.3
: 3.6.3
Assigned To: Arik
Jiri Belka
: Regression
Depends On:
Blocks: 1213937
  Show dependency treegraph
 
Reported: 2015-12-20 14:55 EST by Petr Spacek
Modified: 2016-03-21 09:03 EDT (History)
15 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, templates listed in the 'Add Virtual Machine' window were not filtered based on their data center, which meant a template not residing on the destination data center could be selected and causing the virtual machine creation to fail. Now, templates that do not reside in the destination data center are filtered out so that only eligible templates are listed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-21 09:03:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 51070 ovirt-engine-3.6 MERGED userportal: present only templates in data center on new vm 2015-12-27 08:47 EST
oVirt gerrit 51071 master MERGED userportal: present only templates in data center on new vm 2015-12-27 03:38 EST
oVirt gerrit 51241 master MERGED engine: Blank template doesn't appear in user portal's new vm dialog 2016-01-04 02:36 EST
oVirt gerrit 51275 ovirt-engine-3.6 MERGED engine: Blank template doesn't appear in user portal's new vm dialog 2016-01-05 04:49 EST

  None (edit)
Description Petr Spacek 2015-12-20 14:55:43 EST
Description of problem:
After upgrade to RHEV-M 3.6.1, the "new VM" dialog in User Portal offers VM templates from all data centres in template selection drop box. The problem is that most of the templates are not applicable - when I select a template and attempt to create a VM from it, I get error "The specified Template doesn't exist in the current Data Center."

This is really annoying because now the dialog offers dozens of templates I cannot use anyway so it is hard to use.

Version-Release number of selected component (if applicable):
3.6.1-0.2.el6

How reproducible:
100 %

Steps to Reproduce:
1. Use a setup with multiple DCs.
2. Create some templates in each DC.
3. Open a new VM dialog
4. Select DC1 / cluster 1 and see template drop-down list.

Actual results:
The drop-down list contains templates from all DCs.

Expected results:
The drop-down list contains only templates from selected DC, and only templates usable by the particular user.
Comment 1 Michal Skrivanek 2015-12-21 05:18:59 EST
some of the exceptions mentioned in bug 1293269 might be relevant.

log also shows
ERROR [org.ovirt.engine.core.bll.GetVmTemplatesByStoragePoolIdQuery] (ajp-/127.0.0.1:8702-10) [] Query execution failed due to insufficient permissions.
Comment 2 Michal Skrivanek 2015-12-21 05:20:18 EST
version is rhevm-3.6.1-0.2.el6.noarch
Comment 5 Tomas Jelinek 2016-01-04 02:20:07 EST
since it caused a regression fixed by https://gerrit.ovirt.org/#/c/51241/ which is not yet merged, moving back to post
Comment 7 Jiri Belka 2016-02-12 07:01:53 EST
ok, rhevm-webadmin-portal-3.6.3.1-0.1.el6.noarch
Comment 8 Eyal Edri 2016-03-21 09:03:04 EDT
3.6.3 was GA, closing

Note You need to log in before you can comment on or make changes to this bug.