Bug 1293153 - RFE: have `dnf update' provide better information about broken dependencies
RFE: have `dnf update' provide better information about broken dependencies
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2015-12-20 14:56 EST by N. Jackson
Modified: 2015-12-23 08:32 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2015-12-23 08:32:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description N. Jackson 2015-12-20 14:56:17 EST
Description of problem:
With `dnf update' when there are broken dependencies, in the summary information provided before starting the update, dnf lists the packages that would be skipped in the update due to broken dependencies, but it fails to say why these dependencies are broken. It would be very much more useful if this information were also provided.

Version-Release number of selected component (if applicable):

Fedora GNU/Linux, kernel 4.2.7-300.fc23.x86_64.

$ dnf --version
  Installed: dnf-0:1.1.4-2.fc23.noarch at 2015-11-29 00:26
  Built    : Fedora Project at 2015-11-27 10:25

  Installed: rpm-0:4.13.0-0.rc1.7.fc23.x86_64 at 2015-11-24 19:07
  Built    : Fedora Project at 2015-11-20 13:08

Additional info:

As an example, I recently filed bug https://bugzilla.redhat.com/show_bug.cgi?id=1293143 against the perl package based on the information provided to me by `dnf update', but it turned out that the bug is actually in the polymath package (bug https://bugzilla.redhat.com/show_bug.cgi?id=1292869).

Running `dnf --best update' provided the far more informative message: "Error: package polymake-2.14r1-2.fc23.x86_64 requires perl = 4:5.22.0, but none of the providers can be installed.". If 'dnf update' provided this information straight away, the broken dependency would have been very much less confusing, and the extraneous bug report could have been avoided.

Alternatively, if `dnf update' printed a message suggesting `dnf --best update' when there are broken dependencies of this type, that might be equally useful.

Comment 1 Honza Silhan 2015-12-23 08:32:41 EST
`--best` is suggested in case of "Skipping packages with conflicts". Broken deps are missing requirements and I don't thing overhelming user with these errors is a good idea. He/she can see errors when trying to update manually skipped package due to broken deps one by one.

If this would confuse more users, we can add it to FAQ.

Note You need to log in before you can comment on or make changes to this bug.