Bug 1293236 - Konsole displays KDE start screen and freezes.
Konsole displays KDE start screen and freezes.
Status: CLOSED DUPLICATE of bug 1291260
Product: Fedora
Classification: Fedora
Component: konsole5 (Show other bugs)
22
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-21 02:47 EST by George R. Goffe
Modified: 2016-01-28 06:48 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-28 06:48:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Blind konsole window which is actually working correctly (1.37 MB, image/png)
2016-01-01 15:52 EST, David Tonhofer
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 357063 None None None 2016-01-28 06:48 EST

  None (edit)
Description George R. Goffe 2015-12-21 02:47:38 EST
Description of problem:

I finally got around to rebooting after installing updates. This system is now up to date according to DNF. Konsoles started via saved session display the KDE startup screen and then freeze. They do seem to respond to ctrl-d and commands seem to run but the normal echo of command output is missing. Konsoles started via the desktop menu seem to just display the desktop background or parts of this bug report screen as a background. Same behavior though. ctrl-d exits.

Version-Release number of selected component (if applicable):
konsole5-15.08.3-1.fc22.x86_64
konsole5-part-15.08.3-1.fc22.x86_64
konsole-part-4.14.3-4.fc22.x86_64


How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

I did install xfce.terminal recently. This "xterm" seems to work ok. Konsole is NON functional.

I did a reinstall of the 3 pkgs above. same behavior exhibited. I did get a bunch of messages on the xfce.terminal that I did this from when attempting to start konsole:

konsole
QCoreApplication::arguments: Please instantiate the QApplication object first
fc22-bash 4.3 ~# The font for use in the terminal has not been matched exactly. Perhaps it has not been found properly.
The font for use in the terminal has not been matched exactly. Perhaps it has not been found properly.
0x1955a10 void QWindowPrivate::setTopLevelScreen(QScreen*, bool) ( QScreen(0x11fa850) ): Attempt to set a screen on a child window.
0x18b9e10 void QWindowPrivate::setTopLevelScreen(QScreen*, bool) ( QScreen(0x11fa850) ): Attempt to set a screen on a child window.
0x19003b0 void QWindowPrivate::setTopLevelScreen(QScreen*, bool) ( QScreen(0x11fa850) ): Attempt to set a screen on a child window.
0x181fd00 void QWindowPrivate::setTopLevelScreen(QScreen*, bool) ( QScreen(0x11fa850) ): Attempt to set a screen on a child window.
0x18f2070 void QWindowPrivate::setTopLevelScreen(QScreen*, bool) ( QScreen(0x11fa850) ): Attempt to set a screen on a child window.
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1675, resource id: 54526053, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1678, resource id: 54526053, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1686, resource id: 54526053, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1689, resource id: 54526053, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1696, resource id: 54526053, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1703, resource id: 54526053, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1711, resource id: 54526053, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1717, resource id: 54526053, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1725, resource id: 54526053, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1734, resource id: 54526053, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1743, resource id: 54526053, major code: 130 (Unknown), minor code: 3
QXcbConnection: XCB error: 8 (BadMatch), sequence: 1746, resource id: 54526053, major code: 130 (Unknown), minor code: 3
Comment 1 Thomas Jarosch 2015-12-29 07:26:13 EST
Same issue after installing F22 updates.

For me it shows my wallpaper while moving the window.

This is a dual monitor setup and it only seems to affect
konsole instances started on the second screen.

Upstream bug report from George:
https://bugs.kde.org/show_bug.cgi?id=357063

Personally, I'm going to roll back the updates for now.
Comment 2 George R. Goffe 2015-12-29 13:45:50 EST
Hi,

More info.

I'm finding that Konsoles opened in screen1 and subsequently moved to screen 2 work great... even extra tabs that are requested from time to time work. It's just the init of Konsole that has the problem

George...
Comment 3 David Tonhofer 2016-01-01 15:51:32 EST
New of today on this old system,

Started two konsole instances on updated Fedora 22 (rpm --query konsole5 :
konsole5-15.08.3-1.fc22.x86_64). Dual screen.

The konsole window appears but the content is not filled, i.e. it takes on the bitmap of whatever was underneath, on the secondary screen (screenshot related).

Typing "konsole &" into this blind window works as expected: a new konsole window appears.

Going to a console login on CTRL+ALT+F5 shows konsole with bash subprocesses on pts/1 and pts/2 as expected.

The third opened konsole displays NORMALLY!
Comment 4 David Tonhofer 2016-01-01 15:52 EST
Created attachment 1110932 [details]
Blind konsole window which is actually working correctly
Comment 5 Johannes Pfrang 2016-01-09 06:59:39 EST
Duplicate: RHBZ#1291260
Upstream KDE#357388
Comment 6 Rex Dieter 2016-01-28 06:48:09 EST

*** This bug has been marked as a duplicate of bug 1291260 ***

Note You need to log in before you can comment on or make changes to this bug.