Bug 1293370 - When worker killer is invoked, you get undefined method sort!
When worker killer is invoked, you get undefined method sort!
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance (Show other bugs)
5.5.0
Unspecified Unspecified
unspecified Severity high
: GA
: 5.6.0
Assigned To: Gregg Tanzillo
Pavol Kotvan
: ZStream
Depends On:
Blocks: 1293374
  Show dependency treegraph
 
Reported: 2015-12-21 10:13 EST by Jason Frey
Modified: 2016-06-29 11:22 EDT (History)
7 users (show)

See Also:
Fixed In Version: 5.6.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1293374 (view as bug list)
Environment:
Last Closed: 2016-06-29 11:22:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason Frey 2015-12-21 10:13:59 EST
Description of problem:
When the appliance runs low on memory, the worker killer is invoked.  The following error is raised:

[NoMethodError]: undefined method `sort!' for #<MiqAutomateWorker::ActiveRecord_Relation:0x0000000ca46ff8>  Method:[rescue in monitor]
/gems/ruby-2.0.0-p598/gems/activerecord-4.2.4/lib/active_record/relation/delegation.rb:136:in `method_missing'
/gems/ruby-2.0.0-p598/gems/activerecord-4.2.4/lib/active_record/relation/delegation.rb:99:in `method_missing'
/app/models/miq_server/worker_management/monitor.rb:110:in `block in do_system_limit_exceeded'
/app/models/miq_server/worker_management/monitor.rb:101:in `each'
/app/models/miq_server/worker_management/monitor.rb:101:in `do_system_limit_exceeded'

Version-Release number of selected component (if applicable):
5.5.1

How reproducible:
Always

Steps to Reproduce:
1. Fill up the system with worker
2. Wait for memory to run out
3. See error in log

Actual results:
Boom

Expected results:
The worker killer should kill some workers to reclaim memory, and log an appropriate error message when it does so.

Additional info:
Fixed in upstream PR https://github.com/ManageIQ/manageiq/pull/5916
Comment 4 errata-xmlrpc 2016-06-29 11:22:54 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.