Bug 1293389 - [ppc64le] VM crashes if guest kernel is old
[ppc64le] VM crashes if guest kernel is old
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation (Show other bugs)
3.6.1
Unspecified Unspecified
unspecified Severity high
: ovirt-3.6.1
: ---
Assigned To: Lucy Bopf
Ilanit Stein
docs
:
Depends On:
Blocks: RHEV3.6PPC
  Show dependency treegraph
 
Reported: 2015-12-21 11:00 EST by Ilanit Stein
Modified: 2016-06-30 02:39 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Known Issue
Doc Text:
Red Hat Enterprise Linux 7.2 virtual machines running on PPC64 hosts will crash during hot plug/unplug if the kernel version on the virtual machine is older than kernel-3.10.0-327.2.1.el7, or if the host kernel is older than this version.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-30 02:39:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Docs
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ilanit Stein 2015-12-21 11:00:10 EST
Description of problem:

For guest running on ppc64 host, VM crashes if kernel version is older than
kernel-3.10.0-327.2.1.el7, or if host kernel is older that this version.

This should be documented.

Version-Release number of selected component (if applicable):
engine: rhevm 3.6.1-4
host: rhel 7.2 for ppc
Comment 2 Michal Skrivanek 2015-12-30 04:05:56 EST
it's important to note that this is only due to hotplug actions. Without hotplug attempts the system is running fine. We should advise that older OS releases should avoid such actions
Comment 3 Michal Skrivanek 2016-01-04 10:24:34 EST
Ilanit, can you please test any of those failing/crashing hotplugs on RHEL 6(I guess 6.7) and 7.1? We claimed support....so if it's crashing we have to push a fix to kernel zstreams and document it nevertheless
Comment 4 Ilanit Stein 2016-01-06 11:04:20 EST
The following guests were tested on PPC environment, with rhel 7.2 host, with kernel 3.10.0-327.2.1.el7.ppc64le:

RHEL-7.1-20150219.1-Server-ppc64 kernel 3.10.0-229.el7.ppc64
RHEL-6.7-20150429.0-Server-ppc64 kernel 2.6.32-554.el6.ppc64
RHEL-LE-7.1-20150219.1-Server-ppc64le kernel 3.10.0-229.ae17b.ppc64le

For all guests the hot plug flow from BZ 1292441 (Vnic hot unlug/plug) was run 10 times, and worked OK: no VM crash was seen.
Comment 5 Lucy Bopf 2016-03-10 20:18:41 EST
Hi Ilanit,

Does this bug still need to be documented as a known issue in the Release Notes? Comment #4 suggests that the bug was fixed. Can you please confirm?


Kind Regards,

Lucy
Comment 6 Ilanit Stein 2016-03-13 08:18:09 EDT
In reply to comment #5:

Yes. It needs to be documented.

This bug is not resolved, and not planned to be resolved.

This bug was reported for a guest of rhel 7.2, and kernel version is OLDER than
kernel-3.10.0-327.2.1.el7.

Comment #4, just adds some information:
On guests of rhel 7.1/rhel6.7, this problem was not seen (so only rhel 7.2 guest).
Comment 7 Lucy Bopf 2016-06-30 02:39:46 EDT
This bug was added as a known issue in the RHEV 3.6 Release Notes:

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.6/html-single/Release_Notes/index.html#Known_Issues

Closing.

Note You need to log in before you can comment on or make changes to this bug.