Bug 1293403 - [RFE] Certificate Tool: List
Summary: [RFE] Certificate Tool: List
Keywords:
Status: CLOSED DUPLICATE of bug 1293404
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: RFE
Version: 3.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Mike Barrett
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On: 129
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-12-21 16:59 UTC by Eric Jones
Modified: 2015-12-21 17:25 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
OpenShift Enterprise 3.1
Last Closed: 2015-12-21 17:01:14 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Eric Jones 2015-12-21 16:59:14 UTC
- What is the nature and description of the request?  
As an admin I need the ability to know what certificates and certificate authorities I currently am using in my .kube/config

- Why does the customer need this? (List the business requirements here)  
So that they can know who signed their certs, where they are pointed and which one is specified (in case they are trying to change it)

- How would the customer like to achieve this? (List the functional requirements here)  
Add an oc or kube command that can list/edit/modify the CAs, certificates,and keys listed in the .kube/config on each node/master.
The ability to List the current features. 

- Is there already an existing RFE upstream or in Red Hat Bugzilla?  
Not that I could find  

- List any affected packages or components.  
OpenShift
Kubernetes

Comment 1 Eric Jones 2015-12-21 17:01:14 UTC

*** This bug has been marked as a duplicate of bug 1293404 ***


Note You need to log in before you can comment on or make changes to this bug.