Bug 1293404 - [RFE] Certificate Tool: List
[RFE] Certificate Tool: List
Status: CLOSED DUPLICATE of bug 1293395
Product: OpenShift Container Platform
Classification: Red Hat
Component: RFE (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mike Barrett
Johnny Liu
:
: 1293403 (view as bug list)
Depends On: 1293395
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-21 11:59 EST by Eric Jones
Modified: 2016-04-14 07:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
OpenShift Enterprise 3.1
Last Closed: 2016-04-14 07:54:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Jones 2015-12-21 11:59:39 EST
- What is the nature and description of the request?  
As an admin I need the ability to know what certificates and certificate authorities I currently am using in my .kube/config

- Why does the customer need this? (List the business requirements here)  
So that they can know who signed their certs, where they are pointed and which one is specified (in case they are trying to change it)

- How would the customer like to achieve this? (List the functional requirements here)  
Add an oc or kube command that can list/edit/modify the CAs, certificates,and keys listed in the .kube/config on each node/master.
The ability to List the current features. 

- Is there already an existing RFE upstream or in Red Hat Bugzilla?  
Not that I could find  

- List any affected packages or components.  
OpenShift
Kubernetes
Comment 2 Eric Jones 2015-12-21 12:01:14 EST
*** Bug 1293403 has been marked as a duplicate of this bug. ***
Comment 3 Dan McPherson 2016-04-14 07:54:37 EDT

*** This bug has been marked as a duplicate of bug 1293395 ***

Note You need to log in before you can comment on or make changes to this bug.