Bug 1293437 - Need pcp-iostat functionality in RHEL6 and RHEL7
Need pcp-iostat functionality in RHEL6 and RHEL7
Status: CLOSED DUPLICATE of bug 1248272
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: pcp (Show other bugs)
6.7
Unspecified Unspecified
unspecified Severity urgent
: rc
: ---
Assigned To: Nathan Scott
qe-baseos-tools
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-21 13:47 EST by Dwight (Bud) Brown
Modified: 2016-01-07 18:46 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-07 18:46:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dwight (Bud) Brown 2015-12-21 13:47:36 EST
Description of problem:
I've been told to use PCP for replacement for systat(iostat), and that there is a pcp-iostat module for extracting iostat like data from PCP.  I see that functionality upstream, but when I do a man pcp-iostat I get nothing.  

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. yum install pcp
2. man pcp-iostat
3.

Actual results:
pcp-iostat not available

Expected results:
pcp-iostat available.

Additional info:
Comment 1 Frank Ch. Eigler 2015-12-21 13:50:02 EST
Dwight, pmiostat aka "pcp iostat" has been part of pcp since at least version 3.10.5.  You may be missing the man page due to missing the pcp-doc subrpm?
Comment 3 Dwight (Bud) Brown 2015-12-21 13:58:02 EST
$ pcp iostat
Cannot find a pcp-iostat command to execute
Usage: pcp [options] [[...] command [...]]

# yum update pcp
Loaded plugins: product-id, refresh-packagekit, security, subscription-manager
No Packages marked for Update

# rpm -qa | grep pcp
pcp-conf-3.10.3-3.el6.x86_64
pcp-libs-3.10.3-3.el6.x86_64
python-pcp-3.10.3-3.el6.x86_64
pcp-3.10.3-3.el6.x86_64


so how do i get the latest 3.10.5 to install on 6.7?  yum update is insufficient evidently.
Comment 4 Lukas Berk 2015-12-21 15:22:04 EST
Hi Dwight,

While RHEL6.7 doesn't have a newer version of pcp (3.10.3), you can find the latest rpm's (3.10.9) for el6 upstream on bintray.

https://bintray.com/pcp/el6/pcp/view
Comment 6 Frank Ch. Eigler 2015-12-21 15:31:19 EST
(In reply to Dwight (Bud) Brown from comment #3)
> $ pcp iostat
> Cannot find a pcp-iostat command to execute
> Usage: pcp [options] [[...] command [...]]

Back in 3.10.3, it was called 'pmiostat', which is in the pcp-3.10.3.... subrpm.
Comment 7 Mark Goodwin 2015-12-21 18:12:52 EST
Bud, see Lukas' and Frank's earlier replies.

For RHEL6.x (x < 8), get the bintray repo for RHEL6:

# wget https://bintray.com/pcp/el6/rpm -O bintray-pcp-el6.repo
# mv bintray-pcp-el6.repo /etc/yum.repos.d

On RHEL7.x (x < 2) :
# wget https://bintray.com/pcp/el7/rpm -O bintray-pcp-el7.repo
# mv bintray-pcp-el7.repo /etc/yum.repos.d

PCP is undergoing a lot of development with a lot of incoming RFEs and github requests; faster than we can push stuff into earlier RHEL release streams. As such, I have opened lots of BZs in the past to try and always have latest PCP in earlier RHEL5, RHEL6 and RHEL7 release streams, but rules are rules and it's usually not feasible aka request denied. E.g. see BZ #1229998, BZ #1229999 and many others.

In general, you will always be better off using the latest. Currently version 3.10.9, so make use of the bintray repos when needed, or stock RHEL when available.

Regards
-- Mark
Comment 8 Dwight (Bud) Brown 2015-12-22 10:25:40 EST
(In reply to Lukas Berk from comment #4)
> Hi Dwight,
> 
> While RHEL6.7 doesn't have a newer version of pcp (3.10.3), you can find the
> latest rpm's (3.10.9) for el6 upstream on bintray.
> 
> https://bintray.com/pcp/el6/pcp/view

Customers often are reluctant to install software from 3rd party sites, but will keep this in mind.  Will wait for 6.8 release before trying.
Comment 11 Dwight (Bud) Brown 2015-12-23 12:00:57 EST
I'd like to keep it open until the 3.10.9 is released via errata to both 6 and 7, as that has been cited as the one needed in most of the BZs.  Right now, yum install onseems to get just 3.10.3.
Comment 12 Dwight (Bud) Brown 2015-12-23 12:01:40 EST
If there is another bz already open and tracking the release of 3.10.9 on the two releases, then this can be closed as a duplicate of those.
Comment 16 Nathan Scott 2016-01-07 18:46:59 EST
DUP'ing as part PCP release tracking activity for 6.8, and as per comment #12 - both RHEL 6.8 and 7.3 will rebase to 3.10.9 or later.

*** This bug has been marked as a duplicate of bug 1248272 ***

Note You need to log in before you can comment on or make changes to this bug.