Bug 1293457 - Tabs without element can be added in service dialog
Tabs without element can be added in service dialog
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity medium
: GA
: 5.5.2
Assigned To: Shveta
Shveta
: ZStream
: 1230198 (view as bug list)
Depends On: 1284424
Blocks: 1291702
  Show dependency treegraph
 
Reported: 2015-12-21 14:13 EST by Lucy Fu
Modified: 2016-02-10 10:30 EST (History)
13 users (show)

See Also:
Fixed In Version: 5.5.2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1284424
Environment:
Last Closed: 2016-02-10 10:30:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tab without element (61.22 KB, image/png)
2016-01-19 13:56 EST, Shveta
no flags Details

  None (edit)
Comment 2 Lucy Fu 2015-12-21 16:12:56 EST
*** Bug 1230198 has been marked as a duplicate of this bug. ***
Comment 3 CFME Bot 2015-12-22 09:50:19 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=fc2c70a03f7f75347232cac4fafc100eeb352297

commit fc2c70a03f7f75347232cac4fafc100eeb352297
Merge: 585e17d 90ff877
Author:     Greg McCullough <gmccullo@redhat.com>
AuthorDate: Tue Dec 22 09:33:38 2015 -0500
Commit:     Greg McCullough <gmccullo@redhat.com>
CommitDate: Tue Dec 22 09:33:38 2015 -0500

    Merge branch '5.5.z-service_dialog_validate_1284424' into '5.5.z'
    
    Ensure Dialog / DialogTab / DialogGroup has at least one child element.
    
    Original PR is [here](https://github.com/ManageIQ/manageiq/pull/5602).
    
    Fixed conflicts in specs.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1293457
    
    See merge request !653

 .../miq_ae_customization_controller/dialogs.rb     |  17 ++--
 app/models/dialog.rb                               |  18 +++-
 app/models/dialog_field.rb                         |   2 +-
 app/models/dialog_field_text_box.rb                |   2 +-
 app/models/dialog_group.rb                         |  12 +++
 app/models/dialog_tab.rb                           |  13 +++
 app/models/mixins/dialog_mixin.rb                  |  15 ---
 app/models/resource_action_workflow.rb             |   2 +-
 .../orchestration_template_dialog_service.rb       |   2 +
 spec/controllers/host_controller_spec.rb           |   4 +-
 .../dialogs_spec.rb                                |  82 +++++++++++++++-
 spec/factories/dialog.rb                           |   2 +
 spec/factories/dialog_group.rb                     |   2 +
 spec/factories/dialog_tab.rb                       |   2 +
 spec/models/dialog_field_check_box_spec.rb         |  14 +--
 spec/models/dialog_field_spec.rb                   |   4 +-
 spec/models/dialog_field_text_box_spec.rb          |  10 +-
 spec/models/dialog_group_spec.rb                   |  18 ++++
 spec/models/dialog_spec.rb                         | 106 ++++++++++-----------
 spec/models/dialog_tab_spec.rb                     |  18 ++++
 spec/models/resource_action_workflow_spec.rb       |   8 +-
 spec/services/dialog_import_service_spec.rb        |   8 +-
 22 files changed, 246 insertions(+), 115 deletions(-)
Comment 5 Shveta 2016-01-19 13:56 EST
Created attachment 1116317 [details]
tab without element

Service dialog tab cannot be added without element.
Validation message is shown. 
Verified in 5.5.2.1.20160114044944_395c086
Comment 6 errata-xmlrpc 2016-02-10 10:30:03 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0159

Note You need to log in before you can comment on or make changes to this bug.