Bug 1293621 - Should not change the case of $logdir
Should not change the case of $logdir
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: logwatch (Show other bugs)
6.7
All Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Jan Synacek
Martin Frodl
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-22 07:59 EST by Martin Frodl
Modified: 2016-01-11 08:23 EST (History)
2 users (show)

See Also:
Fixed In Version: logwatch-7.3.6-54.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 205104
Environment:
Last Closed: 2016-01-11 08:23:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch (651 bytes, patch)
2016-01-04 08:00 EST, Jan Synacek
no flags Details | Diff

  None (edit)
Description Martin Frodl 2015-12-22 07:59:32 EST
Description of problem:

The issue described below, which was fixed years ago as bug 205104 in RHEL 4, still persists in RHEL 6. Tested with the --logdir command-line option as well as the LogDir configuration directive.

Version-Release number of selected component (if applicable):
logwatch-7.3.6-52.el6.noarch

+++ This bug was initially created as a clone of Bug #205104 +++

If you have $logdir=/XXX in your logwatch.conf then it will instead try to
access /xxx.  Currently the only way to access logs in a directory that contains
capital letters seems to be creating a symlink with only lowercase letters.  EG
"ln -s /XXX /xxx".
Comment 2 Jan Synacek 2016-01-04 08:00 EST
Created attachment 1111479 [details]
patch
Comment 8 errata-xmlrpc 2016-01-11 08:23:43 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0020.html

Note You need to log in before you can comment on or make changes to this bug.