Bug 1293624 - Should not change the case of $logdir
Should not change the case of $logdir
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: logwatch (Show other bugs)
7.2
All Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Jan Synacek
Martin Frodl
: Patch
Depends On:
Blocks: 1289485 1313485
  Show dependency treegraph
 
Reported: 2015-12-22 08:04 EST by Martin Frodl
Modified: 2016-11-03 23:30 EDT (History)
3 users (show)

See Also:
Fixed In Version: logwatch-7.4.0-29.20130522svn140.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 205104
Environment:
Last Closed: 2016-11-03 23:30:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Frodl 2015-12-22 08:04:34 EST
Description of problem:

The issue described below, which was fixed years ago as bug 205104 in RHEL 4, still persists in RHEL 7. Tested with the --logdir command-line option as well as the LogDir configuration directive.

Version-Release number of selected component (if applicable):
logwatch-7.4.0-28.20130522svn140.el7.noarch

+++ This bug was initially created as a clone of Bug #205104 +++

If you have $logdir=/XXX in your logwatch.conf then it will instead try to
access /xxx.  Currently the only way to access logs in a directory that contains
capital letters seems to be creating a symlink with only lowercase letters.  EG
"ln -s /XXX /xxx".
Comment 7 errata-xmlrpc 2016-11-03 23:30:35 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2312.html

Note You need to log in before you can comment on or make changes to this bug.