Bug 1293650 - Boot loader install failed
Boot loader install failed
Status: CLOSED ERRATA
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: Installation - RHCI (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity medium
: ga
: 1.0
Assigned To: John Matthews
Thom Carlin
Dan Macpherson
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-22 09:46 EST by Thom Carlin
Modified: 2016-09-13 12:23 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-13 12:23:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thom Carlin 2015-12-22 09:46:15 EST
Description of problem:

Boot loader install failed in Anaconda

Version-Release number of selected component (if applicable):

RHCI-6.0-RHEL-7-20151216.t.1

How reproducible:

Uncertain (will update later)

Steps to Reproduce:
1. Install ISO to Bare Metal
2.
3.

Actual results:

Boot loader install

Expected results:

Successful install

Additional info:

Hardware has been used successfully to install ISO.
Comment 2 Thom Carlin 2015-12-22 10:08:45 EST
Worked second time using exact same method
Comment 3 Thom Carlin 2015-12-22 10:20:40 EST
Well, now a different error :-/

KickStart Error: /usr/sbin/authconfig is missing.  Cannot setup authentication.

Running memory test to see if it is a hardware issue.
Comment 4 Thom Carlin 2015-12-22 15:13:08 EST
Memory test + CPU test passed.

Trying install with 20151222.t.0
Comment 5 Thom Carlin 2015-12-22 15:20:27 EST
BootLoaderError: boot loader install failed (2nd occurrence)

stage2dev: existing 512 MiB partition sda1 (85) with existing cfs filesystem mounted at /boot
self:<pyanaconda.bootloader.GRUB2 object at 0x<hex_address>>
args: []
grub_args: ['--no-floppy', '/dev/sda']
stage1dev: existing 931.51 GiB disk sda (11) eith existing msdos disklabel
rc: 1
Comment 6 Thom Carlin 2015-12-22 15:52:56 EST
s/cfs/xfs/ in Comment 5.
Comment 7 Thom Carlin 2015-12-23 08:41:17 EST
doesn't seem to be a hardware problem.
Comment 8 Thom Carlin 2015-12-23 18:21:42 EST
Worked on the 4th time so this is an intermittent issue for now.
Comment 9 Thom Carlin 2016-01-15 15:41:01 EST
Reoccurred with RHCI-6.0-RHEL-7-20160115.t.0

First time: Panic that went off screen
Second time:  Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
Third time: Boot loader install failed

Trying wiping partitions and reinstalling
Comment 10 Thom Carlin 2016-01-15 15:49:43 EST
From https://bugzilla.redhat.com/show_bug.cgi?id=1228405
If so, I'd like to see the output from 'parted -s /dev/sda u s p free'

It looks like grub2 didn't recognize the biosboot partition
Comment 11 Thom Carlin 2016-01-18 10:19:27 EST
Authentication error occurred again - splitting off to new bz.
Comment 12 Thom Carlin 2016-07-13 09:12:52 EDT
Haven't seen this issue in QCI 1.2 -- moving to VERIFIED
Comment 18 errata-xmlrpc 2016-09-13 12:23:37 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862

Note You need to log in before you can comment on or make changes to this bug.