Bug 1299530 - msg: /usr/sbin/authconfig is missing. Cannot setup authentication
msg: /usr/sbin/authconfig is missing. Cannot setup authentication
Status: CLOSED ERRATA
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: ISO Installer (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity medium
: ga
: 1.0
Assigned To: John Matthews
James Olin Oden
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-18 10:23 EST by Thom Carlin
Modified: 2016-09-13 12:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-13 12:24:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thom Carlin 2016-01-18 10:23:56 EST
Description of problem:

During install of ISO(s), receive "An unknown error has occurred"

Version-Release number of selected component (if applicable):

RHCI-6.0-RHEL-7-20151216.t.1
RHCIOOO-7-RHEL-7-20160118.t.0

How reproducible:

Sporatic

Steps to Reproduce:
1. Install ISO
2.
3.

Actual results:

An unknown error has occurred...."Kickstart error: /usr/sbin/authconfig is missing.  Cannot setup authentication."

Expected results:

Successful install

Additional info:

This hardware has installed successfully before.
Comment 1 Thom Carlin 2016-01-18 10:31:26 EST
From Python debugger: Exception yum.Errors.RepoError: RepoError() in <bound method YumSqlitePackageSack.__del__ of <yum.sqlitesack.YumSqlitePackageSack object at 0x<address>> ignored

Stack trace:
/usr/lib64/python2.7/site-packages/pyanaconda/threads.py(211)run()
-> threading.Thread.run(self. *args, *kwargs)
/usr/lib64/python2.7/threading.py(764)run()
-> self.__target(*self.__args, **self.__kwargs)
/usr/lib64/python2.7/site-packages/pyanaconda/install.py(79)doConfiguration()
-> ksdata.authconfig.execute(storage,ksdata,instClass)
/usr/lib64/python2.7/site-packages/pyanaconda/kickstart.py(277)execute()
-> raise KickstartError(msg)
Comment 2 Thom Carlin 2016-01-18 10:43:33 EST
Command is auth --useshadow --enablemd5

From /tmp/packaging.log

ERR yum.verbose.YumPlugins: Plugin "product-id" can't be imported (3 times)
[...]
DEBUG packaging: Installing libldb (304/1251)
DEBUG packaging: Traceback (most recent call last):
DEBUG packaging: File "/usr/libexec/anaconda/anaconda-yum", line 220, in callback
DEBUG packaging: return func(amount, total, key, data)
DEBUG packaging: File "/usr/libexec/anaconda/anaconda-yum", line 342, in inst_open_file
DEBUG packaging: os.unlink(txmbr.po.localPkg())
DEBUG packaging: OSError: [Errno 30] Read-only file system: '/run/install/repo/Packages/libldb-1.1.17-2.el7.x86_64.rpm'
DEBUG packaging: FATAL ERROR: python callback <bound method RPMCallback.callback of <__main__.RPMCallback object at 0x<address>> failed, aborting!
[...]
ERR packaging: systemd is not installed -- can't set default target
Comment 7 James Olin Oden 2016-08-23 11:28:10 EDT
Verified in QCI-1.0-RHEL-7-20160819.t.0

And really this has not been seen for quite some time.
Comment 9 errata-xmlrpc 2016-09-13 12:24:13 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862

Note You need to log in before you can comment on or make changes to this bug.