Bug 129369 - Calls to set* methods from within proxy classes don't flag modified
Calls to set* methods from within proxy classes don't flag modified
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/R&D (Show other bugs)
RHN Devel
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ryan Bloom
Fanny Augustin
:
: 129685 (view as bug list)
Depends On:
Blocks: rhnMilestone1
  Show dependency treegraph
 
Reported: 2004-08-06 20:59 EDT by Mike McCune
Modified: 2007-04-18 13:10 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-22 14:41:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike McCune 2004-08-06 20:59:05 EDT
If you have a proxy persistence class, for example, Session, and from
within SessionImpl you call a public set method on one of the columns:

    public void setExpiresMillis(long expIn) {
        setExpires(expIn / 1000);
    }

the call to setExpires doesn't actually flag the Proxy that this
method has been called, it only gets flagged if someone from outside
the class calls it.  This means that if you call:

s.setExpiresMillis(someval);
SessionFactory.commit(s);

it will not save the expiration time.

The only way to store a new expiration time on a Session object is to
call setExpires().

This means we can't have convienience methods on classes if this isn't
fixed.
Comment 1 Ryan Bloom 2004-08-17 10:16:32 EDT
*** Bug 129685 has been marked as a duplicate of this bug. ***
Comment 2 Ryan Bloom 2004-10-22 14:41:01 EDT
we're using hibernate now, so this isn't an issue.

Note You need to log in before you can comment on or make changes to this bug.