Bug 1293706 - hooks: Ganesha and Samba hooks are always installed
hooks: Ganesha and Samba hooks are always installed
Status: CLOSED DUPLICATE of bug 1174765
Product: GlusterFS
Classification: Community
Component: scripts (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kaleb KEITHLEY
: Triaged
Depends On:
Blocks: 1293708
  Show dependency treegraph
 
Reported: 2015-12-22 13:54 EST by Kaleb KEITHLEY
Modified: 2015-12-28 07:23 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1293708 (view as bug list)
Environment:
Last Closed: 2015-12-28 07:23:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaleb KEITHLEY 2015-12-22 13:54:33 EST
Description of problem:

The Ganesha and Samba hooks are always installed, even if Ganesha and/or Samba aren't installed or used.

The Ganesha hooks invoke showmount, and if rpcbind isn't running then showmount will hang; this breaks regression tests at least.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Kaleb KEITHLEY 2015-12-22 13:56:53 EST
Ganesha and Samba hook scripts probably should be included in the forthcoming common-ha package.
Comment 2 Kaleb KEITHLEY 2015-12-28 07:23:56 EST
see bus https://bugzilla.redhat.com/show_bug.cgi?id=1174765 and https://bugzilla.redhat.com/show_bug.cgi?id=1294446

*** This bug has been marked as a duplicate of bug 1174765 ***

Note You need to log in before you can comment on or make changes to this bug.