Bug 1293708 - hooks: Ganesha and Samba hooks are always installed
hooks: Ganesha and Samba hooks are always installed
Status: CLOSED DUPLICATE of bug 1174765
Product: GlusterFS
Classification: Community
Component: scripts (Show other bugs)
3.7.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kaleb KEITHLEY
: Triaged
Depends On: 1174765 1293706 1302955
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-22 13:57 EST by Kaleb KEITHLEY
Modified: 2016-01-29 01:34 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1293706
Environment:
Last Closed: 2015-12-28 07:25:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaleb KEITHLEY 2015-12-22 13:57:38 EST
+++ This bug was initially created as a clone of Bug #1293706 +++

Description of problem:

The Ganesha and Samba hooks are always installed, even if Ganesha and/or Samba aren't installed or used.

The Ganesha hooks invoke showmount, and if rpcbind isn't running then showmount will hang; this breaks regression tests at least.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Kaleb KEITHLEY on 2015-12-22 13:56:53 EST ---

Ganesha and Samba hook scripts probably should be included in the forthcoming common-ha package.
Comment 1 Kaleb KEITHLEY 2015-12-22 13:59:13 EST
For 3.7 we need to make the (Ganesha) hooks smarter so that they don't do anything if Ganesha isn't installed or running, and in particular, don't invoke showmount if rpcbind isn't running.
Comment 2 Kaleb KEITHLEY 2015-12-28 07:25:22 EST

*** This bug has been marked as a duplicate of bug 1174765 ***

Note You need to log in before you can comment on or make changes to this bug.