This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1293733 - Amazon t2.nano instance type is not supported
Amazon t2.nano instance type is not supported
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.6.0
Unspecified Unspecified
unspecified Severity low
: GA
: 5.5.2
Assigned To: Joe Vlcek
Jan Krocil
: ZStream
Depends On: 1293731 1293734
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-22 16:31 EST by Chris Pelland
Modified: 2016-02-10 10:30 EST (History)
8 users (show)

See Also:
Fixed In Version: 5.5.2.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1293731
Environment:
Last Closed: 2016-02-10 10:30:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 CFME Bot 2015-12-23 17:49:51 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=19881ca723aaae029edc74f8a5ff6e0bf0ca9ad7

commit 19881ca723aaae029edc74f8a5ff6e0bf0ca9ad7
Merge: cc13c9b c5cb59e
Author:     Jason Frey <jfrey@redhat.com>
AuthorDate: Wed Dec 23 17:29:27 2015 -0500
Commit:     Jason Frey <jfrey@redhat.com>
CommitDate: Wed Dec 23 17:29:27 2015 -0500

    Merge branch 'bz_1293731' into '5.5.z'
    
    Add Amazon t2.nano instance type
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1293733
    
        Original PR:
        https://github.com/ManageIQ/manageiq/pull/5942
    
        Original BZ:
        https://bugzilla.redhat.com/show_bug.cgi?id=1293731
    
        The cherry pick was not clean for the 2 spec files because of the recent
        rspec changes. However the small changes were easy to make and confirm.
    
    See merge request !665

 .../manageiq/providers/amazon/instance_types.rb    | 24 ++++++++++++++++++++++
 .../cloud_manager/refresher_other_region_spec.rb   |  4 ++--
 .../amazon/cloud_manager/refresher_spec.rb         |  4 ++--
 3 files changed, 28 insertions(+), 4 deletions(-)
Comment 2 CFME Bot 2015-12-23 17:49:58 EST
New commit detected on cfme/5.5.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=c5cb59effee0c9437029c6fcf6a5975743014ccf

commit c5cb59effee0c9437029c6fcf6a5975743014ccf
Author:     Joe VLcek <jvlcek@redhat.com>
AuthorDate: Mon Dec 21 11:56:26 2015 -0500
Commit:     Joe VLcek <jvlcek@redhat.com>
CommitDate: Wed Dec 23 11:21:32 2015 -0500

    Add Amazon t2.nano instance type
    
        https://bugzilla.redhat.com/show_bug.cgi?id=1293733
    
        Original PR:
        https://github.com/ManageIQ/manageiq/pull/5942
    
        Original BZ:
        https://bugzilla.redhat.com/show_bug.cgi?id=1293731
    
        The cherry pick was not clean for the 2 spec files because of the recent
        rspec changes. However the small changes were easy to make and confirm.

 .../manageiq/providers/amazon/instance_types.rb    | 24 ++++++++++++++++++++++
 .../cloud_manager/refresher_other_region_spec.rb   |  4 ++--
 .../amazon/cloud_manager/refresher_spec.rb         |  4 ++--
 3 files changed, 28 insertions(+), 4 deletions(-)
Comment 4 Jan Krocil 2016-01-19 05:20:04 EST
Verified fixed in 5.2.2.1 - 5.5.2.1.20160114044944_395c086.

Tested on EC2 East (us-east-1e); AMI used was "Fedora-19.0_HVM-x86_64-2-HVM-Access2".
Comment 5 errata-xmlrpc 2016-02-10 10:30:16 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0159

Note You need to log in before you can comment on or make changes to this bug.