Bug 1293734 - Amazon t2.nano instance type is not supported
Amazon t2.nano instance type is not supported
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.6.0
Unspecified Unspecified
high Severity low
: GA
: 5.4.5
Assigned To: Marcel Hild
Shveta
: ZStream
Depends On: 1293731
Blocks: 1293733
  Show dependency treegraph
 
Reported: 2015-12-22 16:33 EST by Chris Pelland
Modified: 2016-03-29 10:16 EDT (History)
10 users (show)

See Also:
Fixed In Version: 5.4.5.2
Doc Type: Enhancement
Doc Text:
The need arose to add support for Amazon t2.nano instance type in CloudForms Management Engine. As this type was recently added by Amazon, CFME needed to be updated to be able to use the new instance type. With this release, support has been added for Amazon t2.nano instance type.
Story Points: ---
Clone Of: 1293731
Environment:
Last Closed: 2016-03-29 10:16:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
instance type (93.66 KB, image/png)
2016-02-08 17:27 EST, Shveta
no flags Details
shows t2.nano instance type (90.12 KB, image/png)
2016-02-09 16:40 EST, Greg Blomquist
no flags Details

  None (edit)
Comment 1 CFME Bot 2015-12-23 17:49:36 EST
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=1351fa103b36fa513bd1fe73b55b984235e4aaf4

commit 1351fa103b36fa513bd1fe73b55b984235e4aaf4
Author:     Joe VLcek <jvlcek@redhat.com>
AuthorDate: Wed Dec 23 14:01:35 2015 -0500
Commit:     Joe VLcek <jvlcek@redhat.com>
CommitDate: Wed Dec 23 14:01:35 2015 -0500

    Add Amazon t2.nano instance type
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1293734
    
    Original PR:
    https://github.com/ManageIQ/manageiq/pull/5942
    
    Original BZ:
    https://bugzilla.redhat.com/show_bug.cgi?id=1293731
    
    The cherry pick was not clean because of the file layout refactoring.
    However the small changes were easily applied manually.

 lib/Amazon/MiqEc2InstanceTypes.rb                  | 24 ++++++++++++++++++++++
 .../refreshers/ec2_refresher_other_region_spec.rb  |  4 ++--
 .../ems_refresh/refreshers/ec2_refresher_spec.rb   |  4 ++--
 3 files changed, 28 insertions(+), 4 deletions(-)
Comment 2 CFME Bot 2015-12-23 17:49:44 EST
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=ca7894e247c716220b26a03219b7ac034bebc4bb

commit ca7894e247c716220b26a03219b7ac034bebc4bb
Merge: ca8dde7 1351fa1
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Wed Dec 23 17:29:49 2015 -0500
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Wed Dec 23 17:29:49 2015 -0500

    Merge branch 'bz_1293734' into '5.4.z'
    
    Add Amazon t2.nano instance type
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1293734
    
    Original PR:
    https://github.com/ManageIQ/manageiq/pull/5942
    
    Original BZ:
    https://bugzilla.redhat.com/show_bug.cgi?id=1293731
    
    The cherry pick was not clean because of the file layout refactoring.
    However the small changes were easily applied manually.
    
    See merge request !667

 lib/Amazon/MiqEc2InstanceTypes.rb                  | 24 ++++++++++++++++++++++
 .../refreshers/ec2_refresher_other_region_spec.rb  |  4 ++--
 .../ems_refresh/refreshers/ec2_refresher_spec.rb   |  4 ++--
 3 files changed, 28 insertions(+), 4 deletions(-)
Comment 4 Shveta 2016-02-08 17:27 EST
Created attachment 1122293 [details]
instance type

Do not see instance type t2.nano ..
5.4.5.0.20160120124945_d8bf7e3
Comment 5 Greg Blomquist 2016-02-09 16:21:55 EST
The patch is definitely on the 5.4.z branch (back in Dec 23rd).  And the patch looks right.

I'll double check another appliance and see if I can reproduce.
Comment 6 Greg Blomquist 2016-02-09 16:40 EST
Created attachment 1122535 [details]
shows t2.nano instance type

I created a new CFME 5.4.5 appliance and tried this out.  I was able to see the t2.nano instance type at the top of the list of instance types on the "Add a new Service Catalog Item" page when creating a new Amazon service catalog item.

@shveta, can you retest?
Comment 7 Shveta 2016-02-09 16:52:58 EST
Yea i see it .
It depends on the template we choose in catalog tab.

on selecting amzn-ami-hvm-2015.03.rc-0.x86_64-ebs , i was able to see t2.nano instance type.
Comment 9 errata-xmlrpc 2016-03-29 10:16:30 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0171.html

Note You need to log in before you can comment on or make changes to this bug.