Bug 1293788 - (RHEL7) CTDB: SELinux: ctdb disablescript fails to execute because of SELinux avc's
(RHEL7) CTDB: SELinux: ctdb disablescript fails to execute because of SELinux...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy (Show other bugs)
7.2
All Linux
high Severity high
: rc
: ---
Assigned To: Lukas Vrabec
Milos Malik
: ZStream
Depends On:
Blocks: 1290514 1293787
  Show dependency treegraph
 
Reported: 2015-12-23 00:12 EST by surabhi
Modified: 2017-02-13 07:21 EST (History)
12 users (show)

See Also:
Fixed In Version: selinux-policy-3.13.1-66.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1290514
Environment:
Last Closed: 2016-11-03 22:39:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 surabhi 2015-12-23 00:16:24 EST
As per the local policy provided above by Milos, This AVC is not seen. Please include the fix in next selinux-policy update.
Comment 3 Miroslav Grepl 2016-01-04 04:43:02 EST
allow ctdbd_t bin_t : file { setattr };

is caused by /etc/ctdb/events.d/SCRIPT labeling as etc_t. We probably want to introduce a new script type or label it as ctdbd_exec_t and allow setattr.

Could you please re-test it with

chcon -R -t ctdbd_exec_t /etc/ctdb/events.d
Comment 10 Mike McCune 2016-03-28 18:59:28 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 14 errata-xmlrpc 2016-11-03 22:39:19 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2283.html
Comment 15 surabhi 2017-02-13 07:21:29 EST
Verified.

Note You need to log in before you can comment on or make changes to this bug.