Bug 1293963 - [Tier]: can not delete symlinks from client using rm
[Tier]: can not delete symlinks from client using rm
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
mainline
x86_64 Linux
urgent Severity urgent
: ---
: ---
Assigned To: bugs@gluster.org
bugs@gluster.org
: Regression, ZStream
Depends On: 1293903
Blocks: 1293237 1295360
  Show dependency treegraph
 
Reported: 2015-12-23 13:16 EST by Mohammed Rafi KC
Modified: 2016-06-16 09:52 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1293903
: 1295360 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:52:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-12-23 13:19:38 EST
REVIEW: http://review.gluster.org/13074 (tier/unlink: symlink failed to unlink) posted (#1) for review on master by mohammed rafi  kc (rkavunga@redhat.com)
Comment 2 Vijay Bellur 2015-12-23 13:53:26 EST
REVIEW: http://review.gluster.org/13074 (tier/unlink: symlink failed to unlink) posted (#2) for review on master by mohammed rafi  kc (rkavunga@redhat.com)
Comment 3 Vijay Bellur 2015-12-24 10:08:34 EST
REVIEW: http://review.gluster.org/13074 (tier/unlink: symlink failed to unlink) posted (#3) for review on master by mohammed rafi  kc (rkavunga@redhat.com)
Comment 4 Vijay Bellur 2015-12-24 15:47:59 EST
REVIEW: http://review.gluster.org/13074 (tier/unlink: symlink failed to unlink) posted (#4) for review on master by mohammed rafi  kc (rkavunga@redhat.com)
Comment 5 Vijay Bellur 2015-12-29 18:35:25 EST
COMMIT: http://review.gluster.org/13074 committed in master by Dan Lambright (dlambrig@redhat.com) 
------
commit 137b11d616c6086b05c32089903a39334999a76e
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Wed Dec 23 23:37:54 2015 +0530

    tier/unlink: symlink failed to unlink
    
    during unlink of a file, we will get stat just after
    deleting the file, to see if the file is under migration or not.
    
    but this stat call will fail for symlink if the actual file
    was deleted.
    
    So it is better not to send stat request from client if it is
    a symlink as we are not migrating symlink.
    
    Change-Id: Idc033b24fa3522b5261e579889d2195b43419682
    BUG: 1293963
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/13074
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: Dan Lambright <dlambrig@redhat.com>
Comment 6 Niels de Vos 2016-06-16 09:52:16 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.