Bug 1295360 - [Tier]: can not delete symlinks from client using rm
Summary: [Tier]: can not delete symlinks from client using rm
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tiering
Version: 3.7.7
Hardware: x86_64
OS: Linux
urgent
urgent
Target Milestone: ---
Assignee: Mohammed Rafi KC
QA Contact: bugs@gluster.org
URL:
Whiteboard:
Depends On: 1293903 1293963
Blocks: 1293237 glusterfs-3.7.9
TreeView+ depends on / blocked
 
Reported: 2016-01-04 09:05 UTC by Mohammed Rafi KC
Modified: 2016-04-19 07:23 UTC (History)
6 users (show)

Fixed In Version: glusterfs-3.7.9
Doc Type: Bug Fix
Doc Text:
Clone Of: 1293963
Environment:
Last Closed: 2016-04-19 07:23:50 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Vijay Bellur 2016-01-04 09:20:16 UTC
REVIEW: http://review.gluster.org/13164 (tier/unlink: open fd for special file for fdstat) posted (#1) for review on release-3.7 by mohammed rafi  kc (rkavunga@redhat.com)

Comment 2 Vijay Bellur 2016-02-10 05:49:37 UTC
REVIEW: http://review.gluster.org/13164 (tier/unlink: open fd for special file for fdstat) posted (#2) for review on release-3.7 by mohammed rafi  kc (rkavunga@redhat.com)

Comment 3 Vijay Bellur 2016-02-22 14:52:23 UTC
COMMIT: http://review.gluster.org/13164 committed in release-3.7 by Dan Lambright (dlambrig@redhat.com) 
------
commit 28f561b1855d118202de3a6d454d688c1ccb9e6e
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Mon Dec 21 14:18:26 2015 +0530

    tier/unlink: open fd for special file for fdstat
    
    DUring unlink of a file, dht request stat to see whether
    the file is under migration or not. But in posix_unlink
    currently we are opening for regular files. so the fdstat
    for special files are failing with EBAD
    
    backport of>
    >Change-Id: Ic0678e42e7701c3dffb91d98272e664b0fc646b5
    >BUG: 1293256
    >Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    >Reviewed-on: http://review.gluster.org/13034
    >Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
    >Reviewed-by: Susant Palai <spalai@redhat.com>
    >Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    >Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    >Tested-by: Dan Lambright <dlambrig@redhat.com>
    
    Change-Id: Ibad6e97cb052f779520968f0dce15b6fa78a5e1a
    BUG: 1295360
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/13164
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>

Comment 4 Kaushal 2016-04-19 07:23:50 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.9, please open a new bug report.

glusterfs-3.7.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-March/025922.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user


Note You need to log in before you can comment on or make changes to this bug.