This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 129397 - Please upgrade your iproute2 tools or compile proper options in
Please upgrade your iproute2 tools or compile proper options in
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
: 129408 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-07 17:44 EDT by Marco Varanda
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.6.8-1.521
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-20 17:26:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Marco Varanda 2004-08-07 17:44:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)

Description of problem:
After upgrade to kernel 2.6.7-1.494.2.2 I receive a error message 
from cbq rules (running about six mounth - without error).

in /var/log/messages
...
...
Please upgrade your iproute2 tools or compile proper options in
...
...

--------------------------

cbq rule 1

DEVICE=eth0,100Mbit,10Mbit
RATE=30Kbit
WEIGHT=3Kbit
PRIO=4
RULE=*****my_real_IP*****:25,

--------------------------

cbq rule 2

DEVICE=eth0,100Mbit,10Mbit
RATE=30Kbit
WEIGHT=3Kbit
PRIO=4
RULE=,:25

--------------------------




Version-Release number of selected component (if applicable):
kernel-2.6.7-1.494.2.2

How reproducible:
Always

Steps to Reproduce:
1.Define cbq rule
2.cbq start
3.see /var/log/messages
    

Actual Results:  The error message in log

Expected Results:  no error messages, no messages, but cbq is active

Additional info:
Comment 1 Ventsislav Genchev 2004-08-10 04:04:49 EDT
Here is some info ... it might help.. :)

I've tried to add the desired rules manually
and when reached the following line:

/sbin/tc filter add dev eth1 parent 1:0 protocol ip prio 100 u32 match
ip dst 192.168.31.10 classid 1:1001

it crashed with the following message:
RTNETLINK answers: Invalid argument

I suspect something is wrong after the "match".


PS: same problem on i686
Comment 2 Ventsislav Genchev 2004-08-10 04:06:18 EDT
*** Bug 129408 has been marked as a duplicate of this bug. ***
Comment 3 Marco Varanda 2004-08-13 21:38:35 EDT
I tried to upgrade iproute2-2.4.7-14 (original FC2) to newer version
iproute2-2.6.7, but didn't work too - same message error appear

http://ftp.nest.pld-linux.org/pool-group/Networking/Admin/iproute2-
2.6.7-0.1.i386.rpm

Comment 4 Marco Varanda 2004-08-20 17:26:53 EDT
OK !

New version of kernel 2.6.8-1.521  seems corrected this problem.


Thanks

Note You need to log in before you can comment on or make changes to this bug.