This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 129398 - nautilus does not show windows servers when Network Servers is selected
nautilus does not show windows servers when Network Servers is selected
Status: CLOSED DUPLICATE of bug 122292
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-07 17:49 EDT by Scot Harris
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Scot Harris 2004-08-07 17:49:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040706 Firefox/0.9.1

Description of problem:
When using nautilus to browse the network none of the servers on the
network show up in the Windows Network window.  

SMB services are working.  findsmb shows a list of servers available
on the network and connections can be made to the resources on those
servers with out problem.  

Under Fedora Core 1 when the Network Servers item is selected I get a
set of icons representing all of the Windows servers on the network. 
Selecting one of those icons prompts for password information and then
a window with the shares available on that server is presented.  This
does not happen with Fedora Core 2.

I have verified that the firewall is not a problem, iptables has been
disabled and/or smb ports have been allowed through the firewall.

This problem has been seen on four different Fedora Core 2 systems, 3
desktops systems and 1 laptop.

I can run findsmb and see a list of servers on the network.  I can
also run smbclient -L SERVERNAME and get a list of resources on those
servers.  So it appears that samba services are working correctly.

I don't see any error messages in the log files for samba or in
/var/log/messages or /var/log/secure.

On one system I removed all samba packages and nautilus and
reinstalled.  Had the same results when I re-tested.

Since access to samba shares appears to work via other mechanisims I
believe this is a problem with nautilus and not samba.



Version-Release number of selected component (if applicable):
nautilus-2.6.0-4

How reproducible:
Always

Steps to Reproduce:
1.Select Network Servers from main menu
2.Select Windows Network icon
3.No servers are listed in the Windows Network window
    

Actual Results:  None of the windows servers on the network are shown
in the Windows Network window.

Expected Results:  An icon for each windows sever on the network
should be shown in the Windows Network window.

Additional info:
Comment 1 Steve Cowles 2004-08-09 17:18:46 EDT
I can confirm observing the same behavior the originator of this bug 
report (Scot Harris) describes using nautilus on my FC2 system. 
Although if I switch to using KDE's konqueror, smb browsing works 
like it should. So it looks like this problem has something to do 
with how nautilus obtains a list of registered domains/hosts on ones 
network.
Comment 2 Don Himelrick 2004-09-19 14:49:00 EDT
I think this is a dupe of 122292.   BTW, after some of the recent
updates, this has started workng for me.
Comment 3 Alexander Larsson 2004-09-21 10:08:49 EDT

*** This bug has been marked as a duplicate of 122292 ***
Comment 4 Red Hat Bugzilla 2006-02-21 14:05:02 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.