Bug 1294005 - [abrt] dnf: i18n.py:44:write:UnicodeEncodeError: 'ascii' codec can't encode character '\xae' in position 64: ordinal not in range(128)
[abrt] dnf: i18n.py:44:write:UnicodeEncodeError: 'ascii' codec can't encode c...
Status: CLOSED DUPLICATE of bug 1295090
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:07a95ee3b53c322f384b8330e40...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-23 20:39 EST by Andrej Podzimek
Modified: 2016-01-04 07:57 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-04 07:57:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: _var_log_dnf.log (2.62 MB, text/plain)
2015-12-23 20:39 EST, Andrej Podzimek
no flags Details
File: backtrace (1.39 KB, text/plain)
2015-12-23 20:39 EST, Andrej Podzimek
no flags Details
File: dnf-makecache.log (11.61 KB, text/plain)
2015-12-23 20:39 EST, Andrej Podzimek
no flags Details
File: environ (2.14 KB, text/plain)
2015-12-23 20:39 EST, Andrej Podzimek
no flags Details

  None (edit)
Description Andrej Podzimek 2015-12-23 20:39:13 EST
Version-Release number of selected component:
dnf-1.1.4-2.fc23

Additional info:
reporter:       libreport-2.6.3
cmdline:        /usr/bin/python3 -OO /bin/dnf search firmware
executable:     /bin/dnf
kernel:         4.2.7-300.fc23.x86_64
runlevel:       N 5
type:           Python3
uid:            0

Truncated backtrace:
i18n.py:44:write:UnicodeEncodeError: 'ascii' codec can't encode character '\xae' in position 64: ordinal not in range(128)

Traceback (most recent call last):
  File "/bin/dnf", line 57, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 174, in user_main
    errcode = main(args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 60, in main
    return _main(base, args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 112, in _main
    cli.run()
  File "/usr/lib/python3.4/site-packages/dnf/cli/cli.py", line 1091, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python3.4/site-packages/dnf/cli/commands/search.py", line 106, in run
    return self._search(extcmds)
  File "/usr/lib/python3.4/site-packages/dnf/cli/commands/search.py", line 81, in _search
    args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/output.py", line 784, in matchcallback
    print(msg)
  File "/usr/lib/python3.4/site-packages/dnf/i18n.py", line 44, in write
    self.stream.write(s)
UnicodeEncodeError: 'ascii' codec can't encode character '\xae' in position 64: ordinal not in range(128)

Local variables in innermost frame:
s: 'ipw2100-\x1b[1mfirmware\x1b(B\x1b[m.noarch : \x1b[1mFirmware\x1b(B\x1b[m for Intel® PRO/Wireless 2100 network adaptors'
self: <dnf.i18n.UnicodeStream object at 0x7f3437189fd0>
Comment 1 Andrej Podzimek 2015-12-23 20:39:30 EST
Created attachment 1109070 [details]
File: _var_log_dnf.log
Comment 2 Andrej Podzimek 2015-12-23 20:39:32 EST
Created attachment 1109071 [details]
File: backtrace
Comment 3 Andrej Podzimek 2015-12-23 20:39:33 EST
Created attachment 1109072 [details]
File: dnf-makecache.log
Comment 4 Andrej Podzimek 2015-12-23 20:39:35 EST
Created attachment 1109073 [details]
File: environ
Comment 5 Honza Silhan 2016-01-04 07:57:52 EST

*** This bug has been marked as a duplicate of bug 1295090 ***

Note You need to log in before you can comment on or make changes to this bug.