Bug 1295090 - [abrt] dnf: i18n.py:44:write:UnicodeEncodeError: 'ascii' codec can't encode character '\xe6' in position 54: ordinal not in range(128)
[abrt] dnf: i18n.py:44:write:UnicodeEncodeError: 'ascii' codec can't encode c...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: rpm-software-management
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:eacc40a61cf7f4e9a8faeb8f320...
: EasyFix, i18n, Reopened, Triaged
: 1273844 1279356 1294004 1294005 1294305 1294514 1294656 1294903 1302190 1317191 1322294 1329877 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-02 05:16 EST by Artem
Modified: 2016-08-27 06:21 EDT (History)
17 users (show)

See Also:
Fixed In Version: dnf-1.1.10-1.fc24 dnf-1.1.10-1.fc23 dnf-1.1.10-1.fc25
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-19 15:51:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: _var_log_dnf.log (228.38 KB, text/plain)
2016-01-02 05:16 EST, Artem
no flags Details
File: _var_tmp_dnf-gtema-ajIf1w_dnf.librepo.log (2.39 MB, text/plain)
2016-01-02 05:17 EST, Artem
no flags Details
File: _var_tmp_dnf-gtema-ajIf1w_dnf.log (128.71 KB, text/plain)
2016-01-02 05:17 EST, Artem
no flags Details
File: _var_tmp_dnf-gtema-ajIf1w_dnf.rpm.log (2.06 KB, text/plain)
2016-01-02 05:17 EST, Artem
no flags Details
File: _var_tmp_dnf-gtema-ajIf1w_hawkey.log (118.90 KB, text/plain)
2016-01-02 05:17 EST, Artem
no flags Details
File: backtrace (1.35 KB, text/plain)
2016-01-02 05:17 EST, Artem
no flags Details
File: dnf-makecache.log (273.73 KB, text/plain)
2016-01-02 05:17 EST, Artem
no flags Details
File: environ (3.60 KB, text/plain)
2016-01-02 05:17 EST, Artem
no flags Details

  None (edit)
Description Artem 2016-01-02 05:16:49 EST
Description of problem:
'dnf search git'

Version-Release number of selected component:
dnf-1.1.5-1.fc23

Additional info:
reporter:       libreport-2.6.3
cmdline:        /usr/bin/python3 /usr/bin/dnf search git
executable:     /usr/bin/dnf
kernel:         4.2.8-300.fc23.x86_64
runlevel:       N 5
type:           Python3
uid:            1000

Truncated backtrace:
i18n.py:44:write:UnicodeEncodeError: 'ascii' codec can't encode character '\xe6' in position 54: ordinal not in range(128)

Traceback (most recent call last):
  File "/usr/bin/dnf", line 57, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 174, in user_main
    errcode = main(args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 60, in main
    return _main(base, args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 112, in _main
    cli.run()
  File "/usr/lib/python3.4/site-packages/dnf/cli/cli.py", line 1095, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python3.4/site-packages/dnf/cli/commands/search.py", line 106, in run
    return self._search(extcmds)
  File "/usr/lib/python3.4/site-packages/dnf/cli/commands/search.py", line 81, in _search
    args)
  File "/usr/lib/python3.4/site-packages/dnf/cli/output.py", line 784, in matchcallback
    print(msg)
  File "/usr/lib/python3.4/site-packages/dnf/i18n.py", line 44, in write
    self.stream.write(s)
UnicodeEncodeError: 'ascii' codec can't encode character '\xe6' in position 54: ordinal not in range(128)

Local variables in innermost frame:
s: '\x1b[1mgit\x1b(B\x1b[m-daemon.x86_64 : \x1b[1mGit\x1b(B\x1b[m protocol dæmon'
self: <dnf.i18n.UnicodeStream object at 0x7fd4c7e52fd0>
Comment 1 Artem 2016-01-02 05:16:57 EST
Created attachment 1110993 [details]
File: _var_log_dnf.log
Comment 2 Artem 2016-01-02 05:17:11 EST
Created attachment 1110994 [details]
File: _var_tmp_dnf-gtema-ajIf1w_dnf.librepo.log
Comment 3 Artem 2016-01-02 05:17:13 EST
Created attachment 1110995 [details]
File: _var_tmp_dnf-gtema-ajIf1w_dnf.log
Comment 4 Artem 2016-01-02 05:17:15 EST
Created attachment 1110996 [details]
File: _var_tmp_dnf-gtema-ajIf1w_dnf.rpm.log
Comment 5 Artem 2016-01-02 05:17:17 EST
Created attachment 1110997 [details]
File: _var_tmp_dnf-gtema-ajIf1w_hawkey.log
Comment 6 Artem 2016-01-02 05:17:18 EST
Created attachment 1110998 [details]
File: backtrace
Comment 7 Artem 2016-01-02 05:17:21 EST
Created attachment 1110999 [details]
File: dnf-makecache.log
Comment 8 Artem 2016-01-02 05:17:23 EST
Created attachment 1111000 [details]
File: environ
Comment 9 Honza Silhan 2016-01-04 07:32:39 EST
Thanks for the report. we'll take a look.
Comment 10 Honza Silhan 2016-01-04 07:57:20 EST
*** Bug 1294514 has been marked as a duplicate of this bug. ***
Comment 11 Jaroslav Mracek 2016-01-04 07:57:35 EST
*** Bug 1294656 has been marked as a duplicate of this bug. ***
Comment 12 Honza Silhan 2016-01-04 07:57:52 EST
*** Bug 1294005 has been marked as a duplicate of this bug. ***
Comment 13 Honza Silhan 2016-01-04 07:58:04 EST
*** Bug 1294004 has been marked as a duplicate of this bug. ***
Comment 14 Jaroslav Mracek 2016-01-04 08:07:33 EST
*** Bug 1294305 has been marked as a duplicate of this bug. ***
Comment 15 Fedora Admin XMLRPC Client 2016-07-08 05:33:48 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 16 Štěpán Smetana 2016-08-01 04:50:13 EDT
Works for me.
Should be fixed in dnf-1.1.9 (Take a look at this commit https://github.com/rpm-software-management/dnf/commit/93159e360f0b6150e598bba783e22ca113201a40)
In case reopen this bug.
Thanks
Comment 17 Štěpán Smetana 2016-08-01 06:03:15 EDT
*** Bug 1322294 has been marked as a duplicate of this bug. ***
Comment 18 Štěpán Smetana 2016-08-01 06:19:02 EDT
*** Bug 1329877 has been marked as a duplicate of this bug. ***
Comment 19 Štěpán Smetana 2016-08-01 06:23:30 EDT
*** Bug 1273844 has been marked as a duplicate of this bug. ***
Comment 20 Štěpán Smetana 2016-08-01 06:25:30 EDT
*** Bug 1294903 has been marked as a duplicate of this bug. ***
Comment 21 Štěpán Smetana 2016-08-01 06:50:35 EDT
*** Bug 1317191 has been marked as a duplicate of this bug. ***
Comment 22 Štěpán Smetana 2016-08-01 07:01:21 EDT
*** Bug 1323453 has been marked as a duplicate of this bug. ***
Comment 23 Štěpán Smetana 2016-08-01 08:41:39 EDT
*** Bug 1279356 has been marked as a duplicate of this bug. ***
Comment 24 Štěpán Smetana 2016-08-01 08:44:12 EDT
*** Bug 1302190 has been marked as a duplicate of this bug. ***
Comment 25 Fedora Update System 2016-08-18 11:19:24 EDT
dnf-1.1.10-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-267f843cda
Comment 26 Fedora Update System 2016-08-18 11:20:38 EDT
dnf-1.1.10-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-8caa619a9e
Comment 27 Fedora Update System 2016-08-18 11:21:41 EDT
dnf-1.1.10-1.fc24 dnf-plugins-core-0.1.21-3.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-878284e0d3
Comment 28 Fedora Update System 2016-08-18 12:52:52 EDT
dnf-1.1.10-1.fc25, dnf-plugins-core-0.1.21-4.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-8caa619a9e
Comment 29 Fedora Update System 2016-08-18 20:22:38 EDT
dnf-1.1.10-1.fc23, dnf-plugins-core-0.1.21-3.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-267f843cda
Comment 30 Fedora Update System 2016-08-18 20:57:51 EDT
dnf-1.1.10-1.fc24, dnf-plugins-core-0.1.21-3.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-878284e0d3
Comment 31 Fedora Update System 2016-08-19 15:50:44 EDT
dnf-1.1.10-1.fc24, dnf-plugins-core-0.1.21-3.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.
Comment 32 Fedora Update System 2016-08-23 11:19:51 EDT
dnf-1.1.10-1.fc23, dnf-plugins-core-0.1.21-3.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 33 Fedora Update System 2016-08-27 06:20:53 EDT
dnf-1.1.10-1.fc25, dnf-plugins-core-0.1.21-4.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.