Bug 1294077 - uses deprecated find -perm +xxx syntax
uses deprecated find -perm +xxx syntax
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: scripts (Show other bugs)
3.7.6
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Niels de Vos
: EasyFix, Triaged
Depends On: 1294223
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-24 08:17 EST by Andreas Metzler
Modified: 2016-06-28 08:13 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.7.12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1294223 (view as bug list)
Environment:
Last Closed: 2016-06-28 08:13:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andreas Metzler 2015-12-24 08:17:29 EST
Hello,

glusterfs/extras/backend-cleanup.sh uses

find [...] -perm +01000 [...]

This GNU extension syntax is deprecated and does not work in GNU findutils 4.5.11 and later. Please change to find -perm /xxx instead.

The new syntax was introduced in 4.2.25 (October 2005) and should therefore be available on any relevant system.

cu Andreas
Comment 1 Vijay Bellur 2015-12-25 14:07:13 EST
REVIEW: http://review.gluster.org/13081 (scripts: correct the usage of -perm in backend-cleanup.sh) posted (#1) for review on release-3.7 by Niels de Vos (ndevos@redhat.com)
Comment 2 Mike McCune 2016-03-28 19:11:51 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 3 Vijay Bellur 2016-04-26 11:27:26 EDT
REVIEW: http://review.gluster.org/13081 (scripts: correct the usage of -perm in backend-cleanup.sh) posted (#2) for review on release-3.7 by Niels de Vos (ndevos@redhat.com)
Comment 4 Vijay Bellur 2016-05-01 09:37:02 EDT
COMMIT: http://review.gluster.org/13081 committed in release-3.7 by Niels de Vos (ndevos@redhat.com) 
------
commit 864248af01ba777a53a0eda4fb7b7c23852a8205
Author: Niels de Vos <ndevos@redhat.com>
Date:   Fri Dec 25 16:19:59 2015 +0100

    scripts: correct the usage of -perm in backend-cleanup.sh
    
    extras/backend-cleanup.sh uses deprecated find -perm +xxx syntax:
    
      find [...] -perm +01000 [...]
    
    This GNU extension syntax is deprecated and does not work in GNU
    findutils 4.5.11 and later. Please change to find -perm /xxx instead.
    
    The new syntax was introduced in 4.2.25 (October 2005) and should
    therefore be available on any relevant system.
    
    Bachport of this change on the master branch:
    > BUG: 1294223
    > Reviewed-on: http://review.gluster.org/13080
    > Change-Id: Ice742957dd24f0ab4f70a8569dff6f2536e9ac1e
    > Reported-by: Andreas Metzler <ametzler@bebt.de>
    > Signed-off-by: Niels de Vos <ndevos@redhat.com>
    
    BUG: 1294077
    Change-Id: Ice742957dd24f0ab4f70a8569dff6f2536e9ac1e
    Reported-by: Andreas Metzler <ametzler@bebt.de>
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: http://review.gluster.org/13081
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
Comment 5 Kaushal 2016-06-28 08:13:22 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.12, please open a new bug report.

glusterfs-3.7.12 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-devel/2016-June/049918.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.