Bug 1294223 - uses deprecated find -perm +xxx syntax
uses deprecated find -perm +xxx syntax
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: scripts (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Niels de Vos
: EasyFix, Triaged
Depends On:
Blocks: 1294077
  Show dependency treegraph
 
Reported: 2015-12-25 10:12 EST by Niels de Vos
Modified: 2016-06-16 09:52 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1294077
Environment:
Last Closed: 2016-06-16 09:52:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Niels de Vos 2015-12-25 10:12:50 EST
+++ This bug was initially created as a clone of Bug #1294077 +++
+++                                                           +++
+++ Use this bug to providea fix for the master branch.       +++

Hello,

glusterfs/extras/backend-cleanup.sh uses

find [...] -perm +01000 [...]

This GNU extension syntax is deprecated and does not work in GNU findutils 4.5.11 and later. Please change to find -perm /xxx instead.

The new syntax was introduced in 4.2.25 (October 2005) and should therefore be available on any relevant system.

cu Andreas
Comment 1 Vijay Bellur 2015-12-25 10:23:45 EST
REVIEW: http://review.gluster.org/13080 (scripts: correct the usage of -perm in backend-cleanup.sh) posted (#1) for review on master by Niels de Vos (ndevos@redhat.com)
Comment 2 Vijay Bellur 2016-01-14 06:41:02 EST
COMMIT: http://review.gluster.org/13080 committed in master by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit 11f6ad26febad1ae7752c2cb7f2c34b1153cae08
Author: Niels de Vos <ndevos@redhat.com>
Date:   Fri Dec 25 16:19:59 2015 +0100

    scripts: correct the usage of -perm in backend-cleanup.sh
    
    extras/backend-cleanup.sh uses deprecated find -perm +xxx syntax:
    
      find [...] -perm +01000 [...]
    
    This GNU extension syntax is deprecated and does not work in GNU
    findutils 4.5.11 and later. Please change to find -perm /xxx instead.
    
    The new syntax was introduced in 4.2.25 (October 2005) and should
    therefore be available on any relevant system.
    
    BUG: 1294223
    Change-Id: Ice742957dd24f0ab4f70a8569dff6f2536e9ac1e
    Reported-by: Andreas Metzler <ametzler@bebt.de>
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: http://review.gluster.org/13080
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
Comment 3 Niels de Vos 2016-06-16 09:52:16 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.