Bug 1294199 - spurious colord authentication request on login for remote session
spurious colord authentication request on login for remote session
Status: CLOSED DUPLICATE of bug 1300937
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: colord (Show other bugs)
7.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Richard Hughes
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-12-25 05:44 EST by Pierre Ossman
Modified: 2017-07-26 13:08 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-07-26 13:08:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 751775 None None None 2016-08-31 11:30 EDT

  None (edit)
Description Pierre Ossman 2015-12-25 05:44:11 EST
Recent versions of colord has switched from rejecting requests for remote sessions, to requiring authentication (commit 26dc57de). Unfortunately Gnome makes such requests whenever it sees a new monitor. That means you get evil focus stealing modal dialog boxes without user interaction.

Prime case is a VNC session. You'll get one dialog on login, and another as VNC adds new monitors to deal with client multi-head.



Duplicate of bug 1149893 since RHEL has now been upgraded to a version of Gnome with this bug. Upstream bug:

https://bugzilla.gnome.org/show_bug.cgi?id=751775
Comment 3 Chris Van Hoof 2017-07-26 13:08:41 EDT

*** This bug has been marked as a duplicate of bug 1300937 ***

Note You need to log in before you can comment on or make changes to this bug.