Bug 1300937 - VNC session requires administrator login to create a color managed device
VNC session requires administrator login to create a color managed device
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-settings-daemon (Show other bugs)
7.2
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Rui Matos
Desktop QE
:
: 1294199 (view as bug list)
Depends On:
Blocks: 1203710 1297830 1313485
  Show dependency treegraph
 
Reported: 2016-01-22 02:08 EST by Siteshwar Vashisht
Modified: 2017-09-13 03:34 EDT (History)
7 users (show)

See Also:
Fixed In Version: gnome-settings-daemon-3.14.4-11.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 02:07:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vnc-color.png (59.77 KB, image/png)
2016-01-22 02:08 EST, Siteshwar Vashisht
no flags Details

  None (edit)
Description Siteshwar Vashisht 2016-01-22 02:08:03 EST
Created attachment 1117125 [details]
vnc-color.png

Description of problem:
VNC session requires administrator login to create a color managed device

Version-Release number of selected component (if applicable):
tigervnc-server-minimal-1.3.1-3.el7.x86_64
tigervnc-1.3.1-3.el7.x86_64
tigervnc-server-1.3.1-3.el7.x86_64
colord-1.2.7-2.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Set up a vnc session by following stesp from https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/7/html/System_Administrators_Guide/ch-TigerVNC.html
2. Login from vnc client


Actual results:
At first login GNOME will request for authentication as Administrator (See attached screenshot vnc-color.png)

Expected results:
GNOME should not request for authentication as Administrator

Additional info:
Upstream bug https://bugzilla.gnome.org/show_bug.cgi?id=751775
Comment 3 Tomas Pelka 2016-02-10 14:17:16 EST
So if I get it correctly colord should rather not start instead of asking for additional permission (password prompt) with remote connections like VNC.
Comment 4 Matthias Clasen 2016-05-16 13:17:54 EDT
Richard, do we have an agreed-on plan for fixing this now ?
Comment 5 Richard Hughes 2016-05-17 10:34:24 EDT
* Tue May 17 2016 Richard Hughes <rhughes@redhat.com> - 3.14.4-11
- Ignore fake VNC devices, they can't be color managed anyway.
Resolves: #1300937
Comment 9 Michael Boisvert 2016-09-06 15:31:26 EDT
Verified on gnome-settings-daemon-3.14.4-12.el7. No admin prompt for color management.
Comment 11 errata-xmlrpc 2016-11-04 02:07:23 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2410.html
Comment 12 Chris Van Hoof 2017-07-26 13:08:41 EDT
*** Bug 1294199 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.